Mobile forwarding not working/bug in outbound rules?

Discussion in '3CX Phone System - General' started by south3, Oct 8, 2010.

Thread Status:
Not open for further replies.
  1. south3

    Joined:
    Aug 28, 2009
    Messages:
    15
    Likes Received:
    0
    Hi,

    I have a problem with forwarding calls to external numbers/my mobile number.

    I have one extension that is tightly restricted so for all outbound rules extension number must be used.

    The problem starts when I try to forward calls to external numbers/my mobile number. Then it say's that there is no outbound rule for that external number. If I make a general rule allowing calls to 0-9 without specifying extension number this works. When I add all extensions except the resctricted one (100-305, 307-999) it stops working.

    This seems like a defect - or have anyone else a good suggestion on how to solve this?

    B.r
    Joakim
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,503
    Likes Received:
    99
    Hi,

    Currently this is a bug in the phonesystem that will be fixed with the next service pack release.
    Unfortunately the only way to make this work is to remove any Extension restrictions from the outbound rules until the next service pack is released.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    just an idea as a work around for this.

    It sounds like your extension 306 is not allowed to make external calls except to forward to this mobile? But with the bug it cant.

    A work around would be as follows:

    1. In the admin turn off allowing outbound calls on the extension 306.
    2. Set up a dummy extension (e.g. 399) and have that as forwarding to the mobile. Do not tell anyone the password so they cannot use it. Hide it from the lists too.
    3. Set up the forwarding rule for 306 to forward to 399 and it should all work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.