Multi Call, CTI Autoanswer

Discussion in 'Ideas' started by solutionsit, Oct 27, 2015.

Multi Call, CTI Autoanswer 4 5 1votes
4/5, 1 vote

  1. solutionsit

    Joined:
    Nov 25, 2014
    Messages:
    62
    Likes Received:
    5
    When a receive more than one call for a extension is enabled and cti is open.
    A call comes in and is answered
    Another call comes in and you hangup the first call, the second call is auto answered with speaker phone.

    There needs to be a way to disable this function as every customer we have runs into this issue.
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,397
    Likes Received:
    273
    This is a limitation of CTI and not 3cx.
    The phone vendors need to update their software first.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Azuroth

    Joined:
    Oct 22, 2015
    Messages:
    6
    Likes Received:
    0
    I had a recent run in with this same issue at a client we just deployed 3CX with. What we did was set the softphone to a different extension than the person was using. IE: Physical phone is set to ext 100, softphone is set to ext 170.

    But yes this is a limitation of CTI.
     
  4. solutionsit

    Joined:
    Nov 25, 2014
    Messages:
    62
    Likes Received:
    5
    Maybe if multiple calls is enabled on the extension to have it set a option on the client to disable call answering functionality but keep presence and pop ups if in CTI mode. Maybe even click to dial.
     
  5. jmtelecom

    Joined:
    Apr 15, 2009
    Messages:
    12
    Likes Received:
    0
    same problem here...

    If an extension has the function "ring my mobile at the same time"
    and 3cx softphone is in the CTI mode .
    and the extension receives a call while the mobile Phones is busy.

    The result is that the 3cx softphone in CTI mode will trigert the extension to auto answer in the handsfree mode :shock:

    This is verry annoying..... Why auto answer just drop THE call or go to voicemail or to THE receptionist Not auto answer on THE extensions!

    the support or 3cx is telling me this is the disign of the soft phone in CTI mode ?
    it can only handle one call at the time?

    please change this as this is a function lots of costumers use "mobile integration"


    Thanks
     
  6. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,397
    Likes Received:
    273
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. solutionsit

    Joined:
    Nov 25, 2014
    Messages:
    62
    Likes Received:
    5
    A way to do this is if multiple calls are selected for a extension that it disables the answer call option, greys it out and does not allow answering from the CTI client
     
  8. solutionsit

    Joined:
    Nov 25, 2014
    Messages:
    62
    Likes Received:
    5
    Found on some other forums
    Option 1
    In any case - the correct way to disable CTI is the following: (Invalidates 3CX Support)

    1) Go to this location
    C:\ProgramData\3CX\Data\Http\Interface\MyPhone
    2) Open the file cti_template.xml
    find the Yealink Phone section
    3) Comment out the phone model you have from the Models section and from the useragent from the Supportedmodels section.
    4) Restart the webserver and your phone will not be recognized with CTI and will work in "Make Call Mode".
    5) Restart 3CXPhone for Windows again.
    NOTE - this action will disable CTI for ALL Models in your network, So if you have 100 T46's, then all 100 of them will work in Make Call Mode.

    Option 2
    bsanders
    On your 3CX server go to C:\ProgramData\3CX\Data\Http\Interface\MyPhone
    There is a fill called cti_template.xml
    Right click and edit it.
    Look for this line. (Be sure you find the one for with the T4x phones....
    <supportedmodels>
    <ua>SIP-T41P</ua>
    <ua>SIP-T42G</ua>
    <ua>SIP-T46G</ua>
    <ua>SIP-T48G</ua>
    </supportedmodels>

    <cticommands delim=";">
    <option value="make_call">http://%%deskphone_useraccount%%:%%deskphone_password%%@%%desktopphone_ipaddress%%/servlet?key=%%dialled_number%%;ENTER</option>
    <option value="answer_call">http://%%deskphone_useraccount%%:%%deskphone_password%%@%%desktopphone_ipaddress%%/servlet?key=OK</option>

    Take the line for answer_call and delete the URL address.
    SO it should look like this.
    <cticommands delim=";">
    <option value="make_call">http://%%deskphone_useraccount%%:%%deskphone_password%%@%%desktopphone_ipaddress%%/servlet?key=%%dialled_number%%;ENTER</option>
    <option value="answer_call"></option>

    This will prevent CTI from sending the OK command to the phone triggering an answer. The side effect is that it will no longer trigger an answer in any state with CTI. Normally not a issue since not a lot of people use CTI to answer the phone but they do use CTI to dial and transfer.


    Both options are unsupported by 3cx. I have opted for option 2 as most don't use the answer button in our experience anyways.
     
  9. Patrick Hogan10

    Joined:
    Nov 23, 2016
    Messages:
    27
    Likes Received:
    1
    Thank you solutionsit!