multiple problems...

Discussion in '3CX Phone System - General' started by bela, Jan 31, 2007.

  1. bela

    Joined:
    Oct 17, 2006
    Messages:
    14
    Likes Received:
    0
    Hi,

    I have just installed 3cx on Windows Server 2003 R2, and have several problems.
    I use the windows firewall on the WAN NIC, and NAT on the LAN NIC.
    I have opened all the necesary ports. (Later on I even turned the firewall off)

    - Incoming calls seems to be fine, however, when a call comes in from a Broadvoice Voip line, the extension rings, but when I pickup there is no audio at all.
    - In "line status" the broadvoice lines sometimes show as not registered (red ball) but when I ring the number it still works.

    - When I dial voicemail (999) from an extenstion i get a busy signal...

    Any help would be appreciated.

    Bela
     
  2. mike_at_software

    Joined:
    Jan 6, 2007
    Messages:
    33
    Likes Received:
    0
    Hi Bela,

    I think the line status problem is a known issue with the status monitor. Archie from 3CX mentioned it in reply to my post here:

    http://www.3cx.com/forums/viewtopic.php?t=801&sid=cf2977d237c5dc02f2bb4fc8311525dc

    I'm not sure I can help with the sound problem.

    Regards.

    Mike
     
  3. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,677
    Likes Received:
    17
    Thanks for the tip Mike.

    In regards to their not being any sound - this would definitely point to a routing or a firewall issue. Probably the SIP protocol is working, since it only requires 5060 but when the audio of the call is setup the router or firewall is blocking it...
     
  4. bela

    Joined:
    Oct 17, 2006
    Messages:
    14
    Likes Received:
    0
    Thanks for the quick response guys.

    I am quite experienced with networking stuff, actually running an ISP...:)
    I thought of this being an RTP problem, I did everything on that Windows 2003 server box. Even disabled the firewall. Did not help.

    Installed an another free SIP PBX (the xycomm) and that one worked straight away..
    So I have no more ideas... :(

    Bela
     
  5. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,677
    Likes Received:
    17
    Hi Bela,

    Ok, you convinced us ;-)

    Could you send us the logs to support at 3cx.com? These can be generated from the support page in the management console. We will check it out. The logs might help us to pin point where exactly the problem is.

    We are about to upload a new build in which we have tested broadvoice. (actually we test it on all builds but we have found that different network settings, for example dynamic IP/Public IP or the ISP using NAT, will effect VOIP provider registration and calls)
     

Share This Page