Music file for 'Music On Hold'

Discussion in '3CX Phone System - General' started by technical-dude, Dec 4, 2007.

  1. technical-dude

    Joined:
    Dec 4, 2007
    Messages:
    2
    Likes Received:
    0
    I'm trying to change the music file for Music on Hold.

    When I select my 8KHz, 16-Bit WAV file, I get the error message: "Extension Number must consist strictly of 4 digits". Seemingly unrelated...

    Any thoughts? :?
     
  2. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    Hi.

    During setup you chose extensions to be 4 digits.

    Check under General settings -> Voicemail and FAX Delivery Settings.
    The extension number for voicemail is propably still default, 999, so you have to enter a new 4 digit number.
     
  3. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    Good morning

    Just to make sure I understand what is happening:

    You open the 3CX management console
    You click on "General Settings" on the left hand menu.
    You then open "Other" at the bottom of the page.
    You then click "Browse" and browse to the wav file you want to use.
    When you select the file you get the error message you mentioned in your post?

    Have you double checked the file name to ensure that you haven't inadvertently used a nonstandard character?

    Have you tried renaming the file (replace the entire name including the extension) to a very simple name?
     
  4. technical-dude

    Joined:
    Dec 4, 2007
    Messages:
    2
    Likes Received:
    0
    Perfect! That has sorted the problem.

    Because the default voice mailbox number was never changed, it needed to be changed first :D
     

Share This Page