Music on Hold not Working

Discussion in '3CX Phone System - General' started by Jamie Snapp, Nov 28, 2017.

Thread Status:
Not open for further replies.
  1. Jamie Snapp

    Joined:
    Feb 20, 2017
    Messages:
    10
    Likes Received:
    0
    I have added 3 wave file to a music on hold playlist. However it does not work. Is there something special I have to do to get this working? I have selected the playlist for call parking however when I park myself or a caller all we hear is dead air.
     
  2. Saqqara

    Saqqara Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    1,099
    Likes Received:
    166
    What version of 3CX ?

    What format are the files, as they have to be Format WAV (PCM, 8 kHz, 16 bit, Mono, Max size: 100MB)

    Do they play correctly on another machine ?
     
    #2 Saqqara, Nov 28, 2017
    Last edited: Nov 28, 2017
  3. vizualpro

    Joined:
    Jul 9, 2016
    Messages:
    88
    Likes Received:
    15
  4. Jamie Snapp

    Joined:
    Feb 20, 2017
    Messages:
    10
    Likes Received:
    0
    The files are wav files in the correct format. I can have each of the 3 files play independently if I take them out of the play list and add them to General MOH.
     
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    420
    Hello @Jamie Snapp

    Are you using windows or Linux PBX? Is this a clean install or an upgrade?
     
  6. Jamie Snapp

    Joined:
    Feb 20, 2017
    Messages:
    10
    Likes Received:
    0
    Windows PBX and Clean install
     
  7. viraltechnology

    Joined:
    Mar 22, 2015
    Messages:
    39
    Likes Received:
    6
    thats interesting, i will have to take my files out of the playlists and see if they will play as well.
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    420
    Navigate to Dashboard / Services and check if the 3CX PhoneSystem 01 AudioProvider service is present and started. Also have you tried restarting the Media Server service?
     
  9. Jamie Snapp

    Joined:
    Feb 20, 2017
    Messages:
    10
    Likes Received:
    0

    This service is not present.
     
  10. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    432
    Likes Received:
    67
    Jamie you have to do a backup, uninstall, re-install, re-load backup. The playlist feature was added in v15.5 and if you did an upgrade of v15 from the management console to v15.5 it won't add the new service to 3CX. The only way to make the playlist feature work on windows that was started with v15 and upgraded to v15.5 is a re-install so it will add the new service that manages the playlist feature.

    https://www.3cx.com/community/threads/v15-5-moh-playlists-not-working.49385/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    YiannisH_3CX likes this.
Thread Status:
Not open for further replies.