Music On Hold

Discussion in '3CX Phone System - General' started by fripsy, Jun 18, 2007.

  1. fripsy

    Joined:
    Jun 18, 2007
    Messages:
    3
    Likes Received:
    0
    Hi All,

    I'm currently struggling with the music on hold feature.
    With an outbound call, it is working fine, however with an inbound call I get the following message in the server log:

    from 'server:0/MediaServer':EP 0000005C@(ACTIVE): Can't send RTP stream to 0.0.0.0:13796 destination unreachable

    The weird thing is that with an outbound call I get the same error from the Mediaserver, but the music is playing.

    I'm using v3.0.1928.0

    Any ideas?

    Frank
     
  2. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    I suspect some party doesn't support re-INVITE. You may bind it to Media Server, and it will work always.
     
  3. fripsy

    Joined:
    Jun 18, 2007
    Messages:
    3
    Likes Received:
    0
    Hi Archie,

    Thanks for the quick reply.

    Just verified the settings, re-invite is checked and bind to mediaserver is also checked, but no go.

    Internal calls on hold don't get the music either, but I guess that's normal.

    meanwhile I've tried every combination external/mediaserver on every line, but no luck. It works perfectly on outbound calls though.

    Frank
     
  4. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    What is your hardware?
    Try to uncheck 'Supports re-invite'
     
  5. fripsy

    Joined:
    Jun 18, 2007
    Messages:
    3
    Likes Received:
    0
    Great Archie!

    Unchecking re-invite did the trick, the one thing I didn't tried.... :wink:

    BTW, it was on a GIZMO VoIP line.

    Everything is working like a charm now!
    Thanks a lot!

    Frank.
     

Share This Page