MWI Light Still Flashing on T46G, but nobody is home.

Discussion in '3CX Phone System - General' started by iwebco, Mar 30, 2017.

Thread Status:
Not open for further replies.
  1. iwebco

    Joined:
    Sep 17, 2009
    Messages:
    6
    Likes Received:
    0
    Hello all,

    Now before the natives get restless, let me say I managed to find some posts here in the forums directing me to modify the template yeahlinkT46T48.ph.xml and set parameter account.1.subscribe_mwi_expires to 3600 (the default value was 86400.

    I did this. I re-provisioned the phones afterwards, and all seemed great... until the next day when I come into work to find all phones are now flashing lights again. Checking to make sure I checked the phones to discover indeed they do NOT have new voice mails. The phones are provisioned with the supported firmware version of 28.81.0.60, and the version of 3CX is the latest v15 fully updated Pro License.

    Any help out there? Thanks
     
  2. JasonNadeau

    JasonNadeau Member

    Joined:
    Oct 14, 2015
    Messages:
    262
    Likes Received:
    46
    It'll blink to indicate missed calls too (depending how it's setup)...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. iwebco

    Joined:
    Sep 17, 2009
    Messages:
    6
    Likes Received:
    0
    That's great to know. I found the field account.X.missed_calllog and it is blank by default, so I changed that to =0, re-provision phone , then looked at the phone, only to discover the setting had NOT gotten updated. Is there another field that is related that would prevent this from provisioning correctly?

    (when I set it manually through the phone interface it works great. THANKS for the tip, but now i need to edit the provisioning template properly so all phones behave similarly.)

    Thanks Jason!
     
    #3 iwebco, Mar 31, 2017
    Last edited: Mar 31, 2017
  4. JasonNadeau

    JasonNadeau Member

    Joined:
    Oct 14, 2015
    Messages:
    262
    Likes Received:
    46
    Glad we've got it narrowed down !
    The line that needs to be in the provisioning is :
    phone_setting.missed_call_power_led_flash.enable = 0
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Also after you do the change in the template make sure to restart the management console service before re-provisioning.
     
Thread Status:
Not open for further replies.