my provider says 3CX is sending sip over 5069

Discussion in '3CX Phone System - General' started by Alejandro, Aug 3, 2017.

Thread Status:
Not open for further replies.
  1. Alejandro

    Joined:
    May 24, 2017
    Messages:
    18
    Likes Received:
    0
    Hi people,
    Having even more problems. My provider (Antel Uruguay) does not use sip registration (no user/password) rather they send a sip message OPTION and 3CX should answer "200 OK".
    Since nothing happens I asked my provider. They checked and then told me 3CX is answering over port 5069 therefore the "200 OK" message never reaches the sip server because Antel only uses sip port 5060.
    How can I get 3CX to send the answer over 5060, the standard sip port?

    At the time being my connection to the sip provider has been automatically truncated by the provider because my 3CX is not answering the OPTION message or rather it is sending it over the wrong port and the answer never reaches destination.

    Thanks for any suggestion.
    Alejandro
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,859
    Likes Received:
    301
    In the SIP trunk settings, are there not options for both the SIP Server Port and the Outbound Proxy Port (if used), to be datafilled by you? This should be on the same page that you put in the Server hostname or IP.
     
  3. Alejandro

    Joined:
    May 24, 2017
    Messages:
    18
    Likes Received:
    0
    I forgot to explain something...
    Got a host with 2 nics and 3CX runs in a qemu VM with 2 nics.
    One nic goes to our LAN connected over a fortigate with one modem having internet.
    The other nic goes at the moment directly to the fibre optic modem which only has access to our providers sip trunk, no internet whatsoever.
    As I run the installation and configuration wizzard I explicitly had it connect to our phones over the LAN and as public address gave our Public IP and FQDN. After that finished I have had no possibility to get https:sip.iai.int:5001 open over browser.
    I can only get to the 3CX over ssh. So, how do I solve my problems? Our public IP going with sip.iai.int will not be reachable over internet, never.
    I would do a cleanup and run the wizzard again if I only new how to tell 3CX to allow me configuration over our local IP:5001.

    Alejandro
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,859
    Likes Received:
    301
    Hmmm....you left out something rather critical. As I have always chosen to use only one NIC, someone else, with experience using two, will have to jump in.
     
  5. Alejandro

    Joined:
    May 24, 2017
    Messages:
    18
    Likes Received:
    0
    sorry for that. My mistake. But I really can't go over one nic. I'm just out of ideas of how to solve this.
     
Thread Status:
Not open for further replies.