Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

MyPhone error

Discussion in '3CX Phone System - General' started by chris.nijdam, May 15, 2013.

Thread Status:
Not open for further replies.
  1. chris.nijdam

    Joined:
    May 15, 2013
    Messages:
    4
    Likes Received:
    0
    Hi guys,

    I'm suffering from a myphone error. Every time i try to open the myphone interface (192.168.1.2:5000/myphone), i get the login screen and when i enter the credentials an error pops up:

    " A critical error occurred and the settings could not be load for the current extension "

    And then i return to the login in screen.

    I did some searching on google but the only page that has come is this one:
    http://www.3cx.com/blog/docs/error-when-loading-3cx-myphone/

    It suggests it is a problem with Microsoft Visual Studio installed on the Phone System.
    However I just did a clean install of the OS and of the PBX (only 3CX is installed, nothing more nothing less). Strangest thing is I was able to login once via myphone, but after relogging in the problem persisted.

    Is there someone out there that has the solution to my problem?

    Specs:
    OS; Windows Server 2008
    3CX v10

    Thanks in advance

    Chris
     
  2. mlump

    mlump New Member

    Joined:
    Feb 24, 2012
    Messages:
    113
    Likes Received:
    0
    Are you using IIS or Abyss? Can you log into MyPhone successfully using any other extensions login credentials? Are you getting this when logging in from the browser or a local install of MyPhone?
     
  3. chris.nijdam

    Joined:
    May 15, 2013
    Messages:
    4
    Likes Received:
    0
    I'm using the Abyss webserver.

    I've tried other extensions with the same result.

    I'm getting this when i log in via a browser, because i keep returing to the login screen i'm not able to install the myphone app.
     
  4. chris.nijdam

    Joined:
    May 15, 2013
    Messages:
    4
    Likes Received:
    0
    Just reinstalling under IIS, same result...
     
  5. mlump

    mlump New Member

    Joined:
    Feb 24, 2012
    Messages:
    113
    Likes Received:
    0
    Did you restore your existing configuration or perform a clean install of 3CX? If not i would try a clean install of 3CX, don't restore a config and see if it still gets the same error. If that's the case its something Server related probably something to do with your .NET Framework installation.
     
  6. chris.nijdam

    Joined:
    May 15, 2013
    Messages:
    4
    Likes Received:
    0
    Update

    Ik kept giving a silverlight error, no matter what i did (reinstalling everything, not using a backup file etc).
    However i managed to run the system properly when I, as an act of desperation, installed Win XP pro on the server. It's not as elegant as server 2008, but hey it works.

    Thanks for your input.

    Chris
     
Thread Status:
Not open for further replies.