MyPhone not installed properly

Discussion in '3CX Phone System - General' started by mike.putnam, Mar 29, 2012.

Thread Status:
Not open for further replies.
  1. mike.putnam

    Joined:
    Feb 17, 2012
    Messages:
    6
    Likes Received:
    0
    Hello,

    I have one user that we needed to reinstall the MyPhone due to a domain change (outside access). When reinstalling MyPhone to run locally (it was installed twice, once with an old ip-based header and one with a old url, I uninstalled both), it's acting differently then all other installations in that it never appears in the system tray. It's as though Windows doesn't think it's running. If I check the notifications area icons, when I make a change to the icon for MyPhone, it tells me it isn't active even though it is currently running.

    Also, during troubleshooting I uninstalled the desktop components and when trying to reinstall, I always get an error that the install log is not accessable. Nothing has changed on this computer other then trying to reinstall MyPhone and desktop components. I am able to install the stand-alone version of the desktop components, the ones used for group policy deployments, and MyPhone does see that they are installed, but integration does not work. I've checked the COM+ configuration and it all looks normal.

    So, not sure what to try next.

    Mike
     
  2. Aboxtech

    Joined:
    Mar 19, 2012
    Messages:
    15
    Likes Received:
    0
    Mike, you might want to try a better UN-installer. Revo UN-installer it will look at the registry as well.
     
  3. mike.putnam

    Joined:
    Feb 17, 2012
    Messages:
    6
    Likes Received:
    0
    Thanks. I'll give that a try and will post the results.

    Mike
     
  4. mike.putnam

    Joined:
    Feb 17, 2012
    Messages:
    6
    Likes Received:
    0
    As an update to this post, I tried a couple of uninstallers and none of them saw the desktop components. I'm still getting an installation error if I try to install the desktop components from the folder created by 3CX. I decided to try and installed the standalone components used for Group Policy deployment. I had an error with the Visual Studio Office Tools, but was able to fix with the MS auto fix program. Once installed, I was able to install the desktop components used for GPO.

    No, the components are there, the add-in in showing in Outlook 2007 and is activated. BUT, the detached version of MyPhone is still now working, as in:

    1. I cannot make a call from Outlook. It says it cannot connect to 3cx MyPhone.
    2. MyPhone is running, but it does not appear in the system tray. There are a couple of posts on this issue in the forums with no solutions posted. I have cleard the IE cache and the Silverlight cache. I reinstalled the latest version of Silverlight from MS (v4.1 & v5).
    3. When looking at the preferences in MyPhone, it says my desktop components are up-to-date, but Outlook Integration is greyed out.

    I have 3 other computers this is working on without an issue.

    I really need to get this going. I'm willing to pay for a support pack, but not sure anyone actually knows how to fix it.

    Mike
     
Thread Status:
Not open for further replies.