Solved New Final Release Upgrade to 15.5.1694.0 fails error log

Discussion in '3CX Phone System - General' started by computatech, Jun 7, 2017.

Thread Status:
Not open for further replies.
  1. computatech

    Joined:
    Oct 21, 2016
    Messages:
    20
    Likes Received:
    1
    When i run the upgrade thats just been realised i get an error when trying to upgrade it (debian 8)

    Upgrading from 15.0.62928.5 to 15.5.1694.0

    error log file
    ....................................................................................................................................
    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following extra packages will be installed:
    libcairo2 libexif12 libgdiplus libgif4 libpixman-1-0 libxcb-render0
    libxcb-shm0 libxrender1
    The following NEW packages will be installed:
    libcairo2 libexif12 libgdiplus libgif4 libpixman-1-0 libxcb-render0
    libxcb-shm0 libxrender1
    The following packages will be upgraded:
    3cxpbx
    1 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
    Need to get 746 kB/82.0 MB of archives.
    After this operation, 15.3 MB of additional disk space will be used.
    Err http://httpredir.debian.org/debian/ jessie/main libcairo2 amd64 1.14.0-2.1+deb8u1
    404 Not Found [IP: 151.101.60.204 80]
    E: Failed to fetch http://httpredir.debian.org/debian/pool/main/c/cairo/libcairo2_1.14.0-2.1+deb8u1_amd64.deb 404 Not Found [IP: 151.101.60.204 80]

    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    Rollback to 15.0.62928.5...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    3cxpbx is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    .......................................................................................................................................................
    Anyone else getting this??
     
  2. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,216
    Likes Received:
    88
    the error is not 3CX Update related but breaks the hold linux update process.
    It can no locate a debian update.

    have you tried to run from root
    apt-get update --fix-missing as suggested
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. computatech

    Joined:
    Oct 21, 2016
    Messages:
    20
    Likes Received:
    1
    i am guessing the 3cx script will be triggering the linux operating system update which fails and in turn doesn't allow the 3cx upgrade to happen i would think many other people will see this error soon as they start upgrading.

    I will try to log into root and do a manual install, will see if this resolves the issue.
     
  4. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,216
    Likes Received:
    88
    from ssh try

    apt-get update
    apt-get upgrade
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. computatech

    Joined:
    Oct 21, 2016
    Messages:
    20
    Likes Received:
    1
    Ok good news

    From SSH i ran as suggested

    apt-get update
    apt-get upgrade

    and then done the upgrade from 3cx uprade web page and its successfully upgraded 15.5 happy days :)
     
    JackH likes this.
Thread Status:
Not open for further replies.