Newbie Help Request

Discussion in '3CX Phone System - General' started by emischell, May 11, 2010.

Thread Status:
Not open for further replies.
  1. emischell

    Joined:
    May 11, 2010
    Messages:
    7
    Likes Received:
    0
    I have installed the 3cx system on a Windows 2003 server and configured a few PCs with softphones. Internal calls to extension are working fine. Audio on in/out calls is one way only (audio is not getting in to the softphone from an outside phone). I am using nexVortex and the trunk indicates that it is registered and their tech support seems to think everything is OK on their end.

    I have setup a service for 3cx on my firewall (Watchguard x500) and created a NAT from the public address to the server running 3cx for 5060 (both) 5090 (tcp) and 9000-9100 (UDP).

    The firewall tests passes step 1, on 2a&b passes with warnings, and the same for Phases 3 and 4. Exit code is 53. I have several other services setup on the firewall so I'm comfortable saying that I have followed the directions in the manual.

    Anywhere in the Management console I should be looking?

    Thanks,
    Eric
     
  2. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Did you set up inbound and outbound rules for these services?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. emischell

    Joined:
    May 11, 2010
    Messages:
    7
    Likes Received:
    0
    Yeah,the inbound rings all extensions (it does) and the outbound strips out a 9 (it does). The calls are going through it is just an audio issue at this point.
     
  4. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    have you specified the public IP you will be presenting in the contact header in the VoIP Provider > Advanced section, and also under Network Settings > Stun Server > Public IP to specify in contact and SDP?

    Paul
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. emischell

    Joined:
    May 11, 2010
    Messages:
    7
    Likes Received:
    0
    Thanks, Paul. I had not done either. I'll test with that.

    My ISP is also going to be replacing some equipment this week because they are seeing packet loss. I'll reply before then if your help fixes it.
     
  6. emischell

    Joined:
    May 11, 2010
    Messages:
    7
    Likes Received:
    0
    Outbound calls - have voice both ways now.

    Inbound calls - no inbound audio on 3cx softphone, cell phone can hear what the person calling from the softphone is saying.
     
  7. emischell

    Joined:
    May 11, 2010
    Messages:
    7
    Likes Received:
    0
    Re-reading the inbound description it is not clear.

    The person receiving the call on the softphone cannot hear any audio. The person who initiated the call can hear what the person on the softphone is saying.
     
  8. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    can you perform a wireshark capture from the machine with the softphone on and post the results here?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,321
    Likes Received:
    253
    I can not get my firewall test to get past 2a.
    it tells me "UDP SIP Port is set to 5060. NO RESPONSE received. Phase 2a check FAILED."

    In firewall checked, STUN is using stun.3cx.com even though STUN is turned off in the network settings. I have also tried my external ip here.

    In my watchguard x500, I have a 1-to-1 nat range as I need my email server to do 1-to-1 as well.
    Also, I have 5060 (both), 5061(both) 5090 (both), 9000-9049 (tcp) and 10000-20000 (udp) from "Any External" to "NAT for External IP to Internal IP"

    I have read changing 1-to-1 NAT to a single helps - but I can not do that. I need the Mail server in there and the license allows for 1 1-to-1 NAT.

    Finally, Firewall Service is turned off on Win7 Device running 3cx.

    I can connect to the server from outside world but no audio.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. albertc

    Joined:
    Nov 21, 2011
    Messages:
    89
    Likes Received:
    0
    Is there a reason why you use TCP instead of UDP for port 9000-9049? I believe 3CX only use UDP for RTP. And that may explain why you have one way audio. When your are streaming outbound audio with UDP 9xxx without any issue, all the incoming UDP 9xxx are not being deliver to your server since 9000-9049 UDP are not mapped.
     
  11. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,321
    Likes Received:
    253
    No reason I was using tcp. I am sure I looked at that 100 times and kept saying "yep that's all right"

    Do I have too many ports open?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. albertc

    Joined:
    Nov 21, 2011
    Messages:
    89
    Likes Received:
    0
    For port 9000-9049, you MUST use UDP. TCP won't work.
     
  13. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,321
    Likes Received:
    253
    Yep got that now. Audio is working.
    We are only doing remote xtnsions not vo-ip.
    Can I close any of those ports?

    And - thank you!!!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. albertc

    Joined:
    Nov 21, 2011
    Messages:
    89
    Likes Received:
    0
    No problem. You can close the 10000-20000 udp. 3CX doesnt listen to them. Also, if you do not use SIP Proxy Manager at a remote location, you can turn off TCP 5090.
     
  15. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,321
    Likes Received:
    253
    Perfect.
    I do need the 1-to-1 nat correct?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. albertc

    Joined:
    Nov 21, 2011
    Messages:
    89
    Likes Received:
    0
    Not with 3CX. And I dont think you'll need to use 1 to 1 NAT for your email server also. In most situation, Port forwarding will do the job just fine. All you need is to forward all the necessary ports your email server required (i.e. TCP/25 for smtp, TCP/143 for IMAP, TCP/80 , 443 for Web mail access, ...etc.).
     
  17. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,321
    Likes Received:
    253
    Good to know. I know our ms exchange server needs it otherwise our email flow stops completely.
    When we changed ISP I forgot to change the 1 to 1. As soon as I did mail started flowing again...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.