Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Nexmo Incoming Calls not working

Discussion in '3CX Phone System - General' started by kiomon, Feb 11, 2018.

Thread Status:
Not open for further replies.
  1. kiomon

    Joined:
    Feb 11, 2018
    Messages:
    4
    Likes Received:
    0
    I am just setting up our 3CX PBX. We have it hosted on our AWS account and we used the PBX Express service to set it up. We have signed up for Nexmo, and linked our Trunk (following the guide in the blog), and everything works great for outbound calls after we made the outbound rule. We then made an inbound rule for the DID, but when we call the number nothing happens. Do we need to configure anything special again at Nexmo for each of the numbers?

    Also it seems like the DNS is taking a while to propogate? On some of our devices, we can resolve https://ourdomain.3cx.us some other ISPs cant resolve our domain yet. Could this be the reason we aren't receiving the calls?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,301
    Likes Received:
    530
    Hello @kiomon

    Make sure that the DIDs are listed the Your numbers section in Nexmos portal. If they are the numbers should be correctly routed to your PBX. DNS propagation should not be related to the issue you are facing as the PBX registers to the provider with its public IP.

    Are the calls hitting the PBX when the DID is called? Do you hear an error message / Busy tone when calling?
     
  3. kiomon

    Joined:
    Feb 11, 2018
    Messages:
    4
    Likes Received:
    0
    Hi! @YiannisH_3CX

    Thanks for the reply. Yes the DID are listed, and no they do NOT hit the PBX. I was able to get it working, but i want to be sure i did it correctly. I selected each number in Nexmo, and selected "Forward to SIP" (the option of where to send the calls was initially blank), and the in the SIP URL i put DIDNUMBER@mydomain.3cx.us and i did this for all the DID numbers and they all now hit the right extenstion and the system works. Is this an ok workaround? Am i doing anything wrong?
     
  4. Sopock

    Sopock Member

    Joined:
    Jul 11, 2012
    Messages:
    447
    Likes Received:
    20
    Someone needs to contact Peter about improving this page:
    We have provided examples for a number of different SIP capable systems
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,301
    Likes Received:
    530
    Glad to see the issue has been resolved. You are correct regarding the extra step and it will be added to our documentation to avoid future confusion. Thank you for pointing it out.
     
Thread Status:
Not open for further replies.