nexVortex and DID Routing Failures

Discussion in '3CX Phone System - General' started by SadienInc, Jan 14, 2010.

Thread Status:
Not open for further replies.
  1. SadienInc

    Joined:
    Sep 16, 2008
    Messages:
    5
    Likes Received:
    0
    DID routing does not work with nexVortex accounts/DID's?

    Version 7 and 8

    DID's can be used to verify the source... but DID routing fails.

    Worked fine with Broadvox.
     
  2. SadienInc

    Joined:
    Sep 16, 2008
    Messages:
    5
    Likes Received:
    0
    It is changed to the DID.

    6155551234, etc...
     
  3. SadienInc

    Joined:
    Sep 16, 2008
    Messages:
    5
    Likes Received:
    0
    I know that 3CX is receiving DID information from nexVortex on some level, because if I do not "verify the source by DID," the inbound calls to that DID fail completely.

    Thus, 3CX must be recognizing DID information from nexVortex... but 3CX's internal routing based on DID doesn't work.

    The only way I can get it to "route" at all, is to set nexVortex up as a "provider" multiple times... one for each DID.

    I can at least use that method to route the call appropriately... however, it doesn't allow for Caller ID / DID renaming, routing, etc...

    Like I said, it worked fine with Broadvox.

    That being said, I still think nexVortex is a superior provider. I just need to get the DID Routing / Renaming to work.
     
  4. support@nexvortex

    Joined:
    Aug 30, 2007
    Messages:
    6
    Likes Received:
    0
    Hello,

    You can configure all of your DIDs under one nexVortex line configuration, but you must configure the Source Identification correctly for them to work. This will require only one set of proxy credentials. If you want to configure each DID as its own Line, you will need a different set of credentials for each Line.

    In the Source Identification section, you must select which header you want to match (usually sip_uri or request line uri), but you may use the To header, or any field you wish, actually. If you use the sip_uri USER part, this corresponds to the 'Translated' value that you configure within your nexVortex web portal.

    If you have additional questions, please open a ticket by emailing support@nexvortex.com directly.

    Thanks,
    nV Support
     
  5. windsornet

    Joined:
    Mar 22, 2009
    Messages:
    2
    Likes Received:
    0
    I had similar issue before I called nexvortex , They have created second id for my other DID no. Try it out.
     
  6. smokeman

    Joined:
    Dec 10, 2010
    Messages:
    50
    Likes Received:
    0
    we just had this pop up also.
    you have to go under voip providers, nexvortex, source id tab, and check the source identification by DID, and add DID, select all., then click ok.

    then, in number routing in nexvortex, you add the number in it's mask field. this makes the call look like number@ip, and allows the call to be accepted by 3cx.

    under each did added to the did tab, you have to do DID/DDI number/mask option on inbound rule type
     
Thread Status:
Not open for further replies.