no audio for a few seconds between clients

Discussion in '3CX Phone System - General' started by Jor3cx, Oct 26, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. Jor3cx

    Joined:
    Oct 26, 2017
    Messages:
    13
    Likes Received:
    1
    I have a problem with 3cx on premiss (windows v15.5).

    In an internal call between 2 devices, there is no audio in the first 2 seconds of the call. After the first 2 seconds the conversation goes well. This is with 2 ios phones, or with 1 ios phone and one yealink at an external location.

    If I do the echo test with * 777 I do not hear any delay. I use direct sip (stun-remote). The firewall test has passed.

    Does anyone have an idea?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,426
    Likes Received:
    458
    Hello @Jor3cx

    Since the common factor of the issue seems to be the IOS clients you should start from there.
    Have you noticed the delay if the clients are on premise connected to the local network or is the delay present only when using 3g/4g
    Are you using the latest clients? Have you tried an Android client to see if you replicate this behaviour?
     
  3. Jor3cx

    Joined:
    Oct 26, 2017
    Messages:
    13
    Likes Received:
    1
    If the clients are on premise connected to the local network i also have the same problem. I am using te latest clients for iphone. I also tried it with android and also have a few seconds delay. Sometimes its 1 second sometimes a bit more.
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,426
    Likes Received:
    458
    Please note that 1-2 seconds delay is normal for a call established on the client. Once you accept the call the client has to send a 200 OK message to establish the call and negotiate the codecs that will be used before the RTP starts. Then the client has to start the audio device of the phone where the delay is. If you were using a Bluetooth audio device which is slower the delay would be more noticeable. This also relies on network speed and traffic. So a couple of seconds of delay is normal and is to be expected.
     
  5. Jor3cx

    Joined:
    Oct 26, 2017
    Messages:
    13
    Likes Received:
    1
    ok, thanx for your reply.
     
Thread Status:
Not open for further replies.