Solved No audio from soft phones but hard phones connect fine

Discussion in '3CX Clients' started by ICENINE, May 11, 2017.

Thread Status:
Not open for further replies.
  1. ICENINE

    Joined:
    May 11, 2017
    Messages:
    2
    Likes Received:
    0
    So I'm setting up a test PBX for my company, we want to virtualize 3CX on Debian in our datacenter. I have the PBX set up and we have hard phones connected, but the Windows, iOS, and Android soft phones will not transmit audio. In our office I have a session border controller set up and the hard phones are connected via that. I ran tshark on the server and captured calls from when the soft phones were on WiFi, 4G, and a call from the Windows client on wifi to the iOS client on 4G. There don't appear to be RTP streams going through the tunnel.
     
    #1 ICENINE, May 11, 2017
    Last edited: May 12, 2017
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    Hello @ICENINE

    I assume that the phones and clients are in a different network than the PBX.
    As the hard phones are behind an SBC that eliminates firewall issues i would assume that the issue is firewall / network related.
    Does the PBX pass the firewall checker? Are the clients configured to use the tunnel?
    And please refrain from sending wireshark captures in the forum as these captures contain sensitive info about your network.
     
  3. ICENINE

    Joined:
    May 11, 2017
    Messages:
    2
    Likes Received:
    0
    I hadn't checked the firewall checker as we were using the 3CX tunnel for both the soft phones and the hard phones. The soft phones are configured to "Use 3CX Tunnel when out of office".
    EDIT:
    We fixed it, UDP traffic wasn't enabled in the firewall. Please delete this thread.
     
    #3 ICENINE, May 12, 2017
    Last edited: May 12, 2017
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    Glad to hear the issue is resolved and thank you for sharing your solution
     
Thread Status:
Not open for further replies.