Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

No Audio on ANY calls

Discussion in 'Android' started by thereverend, Jun 25, 2011.

Thread Status:
Not open for further replies.
  1. thereverend

    thereverend New Member

    Joined:
    May 29, 2011
    Messages:
    100
    Likes Received:
    0
    I have FINALLY got my 3cx for andriod to register to the phone server however.. Whenever i make a call or get a call on it there is not SOUND coming out of my speaker on the HTC EVO. However the MIC portion works. the caller can hear everything i says or do but i cant hear them.. what setting do i have wrong?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    Are you using WiFi or 3G? If WiFi is it on the same network or remotely, on more than one remote site? Do you have STUN set up and working? What does the registration look like in the 3CX server log?
     
  3. thereverend

    thereverend New Member

    Joined:
    May 29, 2011
    Messages:
    100
    Likes Received:
    0
    It was on WIFI on the same network. However i have the SERVER IP address as the EXTERNAL IP ADDRESS so i can use it outside the network wherever there is Wireless internet.

    Extension 211 is registered, contact: sip:211@68.68.178.107:1024;ob

    is what the registration looks like..




     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    Internally, you should be registering with a private IP. You will probably need to set up two profiles, one for internal use, no STUN, registers only to internal 3CX IP. And one for use outside the LAN, probably the one you currently have.

    Because you are currently registering with a public IP, the audio packets are going out on the net, then back in, and it isn't working.
     
Thread Status:
Not open for further replies.