No Audio on Calls (3CX V15)

Discussion in '3CX Phone System - General' started by Michael Menor, Jan 20, 2017.

Thread Status:
Not open for further replies.
  1. Michael Menor

    Joined:
    Dec 30, 2016
    Messages:
    41
    Likes Received:
    0
    I've already opened a case with 3CX, but I figured I'd post it here just in case the community could provide some insight.

    So here's what going on - we are not getting any audio on the phones (inbound, outbound, ext to ext). However, I have tested a successful call from the 3CX client on a Mac.

    Here are the details:
    • We are using 3CX V15.
    • SIP Provider: CallCentric
    • We have forwarded all the necessary ports and the Firewall Check passes.
    • We have provisioned a Yealink T46G, Grandstream GXP2140 and GXP2130 to the system and they are able to send and receive a call, but there is no audio. When we check the CallCentric call reports we see the calls being logged.
    • These phones are configured using the "Direct SIP (STUN remote)" Provisioning Method since they will be remote extensions outside of the data center.
    Not that it matters, but I uploaded a screenshot of my Dashboard.
    The four extensions are the IP phones (1x Yealink T46G, 2x Grandstream GXP2140 and 1x GXP2130). The fifth extension is the 3CX Client (Mac, currently offline).
     

    Attached Files:

  2. Michael Menor

    Joined:
    Dec 30, 2016
    Messages:
    41
    Likes Received:
    0
    We've already performed these steps:

    • Navigate under 3CX Console > Extensions > Edit the extension bound to the Yealink T46 > Phone Provisioning. The ports set under Local Sip and Local RTP ports must be open and forwarded to the local IP address of the phone, on the remote location.
    • For each remote IP Phone located behind the same public IP, the local SIP and local RTP ports must be unique (not overlapping)
     
  3. MRM

    MRM

    Joined:
    Dec 21, 2016
    Messages:
    53
    Likes Received:
    3
    Hi Michael Menor,

    Have you tried going into Extensions > ???? > Options & go down to Troubleshooting and switching on PBX Delivers Audio?

    Please update the post on your findings and if you managed to solve the issue we would be grateful if you could share it with the community.

    Regards
     
  4. Michael Menor

    Joined:
    Dec 30, 2016
    Messages:
    41
    Likes Received:
    0
    @MRM Yes, we have tried that - we still have the same "no audio" issue.

    I've sent the Wireshark and Support Info files to 3CX Support.
     
Thread Status:
Not open for further replies.