No audio on external calls after upgrade to v10**FIXED

Discussion in '3CX Phone System - General' started by dmaunder, Jun 3, 2011.

Thread Status:
Not open for further replies.
  1. dmaunder

    Joined:
    May 6, 2008
    Messages:
    10
    Likes Received:
    0
    I have upgraded last night from Windows 2008 x86 with 3cx v9 to a new virtual machine running Windows 2008 R2 x64 and 3cx v10. Both servers are virtual on the same Hyper-V host, and both have the same ip address (obviously not running at the same time)

    I did a 3cx backup on the old server and restored it on the new server. Everything comes across fine. Phones register fine, external SIP trunks register fine, internal calls are fine. But both inbound and outbound external calls have no audio either way.

    The firewall checker says everything is fine. The RTP ports are same as they were. Calling in to the DR also has no audio.

    Regards
    Daryl
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    Re: No audio on external calls after upgrade to v10

    Looking at the 3CX server log, of a call, is there any indication of a problem (something like..no RTP packets received)?

    If an inside call to the DR has no audio (at least in the past), this has been an indication of missing/incorrectly configured, audio drivers/hardware.
     
  3. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Re: No audio on external calls after upgrade to v10

    If inbound calls also have no audio, you have a firewall problem.

    If calling the DR has no audio, you have a problem of a different dimension. Or a very serious configuration error. Do not look at incorrect source of RTP stream errors in the logs. The problem is not that advanced. To get that message you have to have everything working on the local machine first and everything working on the internal network. Then you can start checking for incorrect source of RTP stream notifications in the logs.

    My honest advice - do not invest time troubleshooting 3CX software in itself. Troubleshoot your network, phone configuration and actual server machine.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. dmaunder

    Joined:
    May 6, 2008
    Messages:
    10
    Likes Received:
    0
    Re: No audio on external calls after upgrade to v10**CHECKIN

    Thanks for your help. I found the problem, I hadnt installed the Desktop Experience feature in Windows Server 2008 R2. Once I did that, everything was fine.
     
  5. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Re: No audio on external calls after upgrade to v10**CHECKIN

    Strictly speaking you do not need desktop experience because all the files we put in 3CX by default are .WAV and .WAV can be played without desktop experience. So this is quite strange. Anyway - in any case, happy you got this working.

    So did you have v9 before on this machine or no? Because if this was the case, V9 could not have worked because v9 needed desktop experience for sure since we were still heavily shipping .mp3 files that will not play without desktop experience installed on the machine.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. dmaunder

    Joined:
    May 6, 2008
    Messages:
    10
    Likes Received:
    0
    Re: No audio on external calls after upgrade to v10**CHECKIN

    No it was a new machine, as I took the opportiunity to change from 32 top 64 bit and upgrade to 2008 R2 server.
     
Thread Status:
Not open for further replies.