No audio - RTP stream not sent

Discussion in '3CX Phone System - General' started by maatwerk3cx, Aug 2, 2012.

Thread Status:
Not open for further replies.
  1. maatwerk3cx

    Joined:
    Aug 2, 2012
    Messages:
    6
    Likes Received:
    0
    Please can somebody help.

    I’m testing the 3CX software with Orbtalk (http://www.orbtalk.co.uk) as the SIP provider.

    I can make and receive calls without problem but there is no audio either direction.

    I’m receiving the message “Can't send RTP stream to 193.104.xxx.xxx:39592 destination unreachable”.

    193.104.xxx.xxx (xxx.xxx replaces origianl ip) is the name of the mediaserver of Orbtalk.

    I also receive:

    No RTP packets were received:remoteAddr=193.104.xxx.xxx:38124,extAddr=77.73.xxx.xxx:9000,localAddr=77.73.xxx.xxx:9000

    77.73.xxx.xxx (xxx.xxx replaces origianl ip) is the name of my server hosting the 3CX software.

    To ensure there is no firewall issue, I’ve turned off all firewalls on the service hosting the 3CX software as well as the Windows 7 client making the calls temporarily.

    I've enabled tracing of the 3CX processes and in the MediaServer.trace.log I see the following error in addition to the above messages:

    C:1.1: Failed to receive incoming stream from 77.73.xxx.xx:10004 WSAError=10054

    Does anybody have any experience of this error or any suggestions to solve it?

    Thanks in advance,
    Tony.
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,321
    Likes Received:
    253
    Have you run the 3cx firewall checker ?
    So, no firewalls are on?
    Are you routing the external ip ports to the 3cx server?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    While the firewall is off, presumably there is still some port forwarding taking place; did you run the firewall checker and did it pass? Have you tried "PBX delivers audio" in the provider set-up? Have you stipulated your IP in the approppriate boxes in the "Settings", "Network" tab for both STUN and Public Ip? You may need to restart the services for the change(s) to take affect. You might need to post more of the log (verbose) or even a Wireshark capture if the above does not resolve.
     
  4. maatwerk3cx

    Joined:
    Aug 2, 2012
    Messages:
    6
    Likes Received:
    0
    Hi Craig.

    Yes, I've run the 3CX firewall checker (Sorry for not mentioning). All tests were paased without any errors or warnings.
     
  5. capitol1

    Joined:
    Jul 11, 2011
    Messages:
    20
    Likes Received:
    0
    If you 're running 3CX v11 on a 64-bit OS, then there is a bug with STUN that will be fixed in the next service pack. For now, you pretty much just have to disable STUN.
     
  6. maatwerk3cx

    Joined:
    Aug 2, 2012
    Messages:
    6
    Likes Received:
    0
    I've run the firewall checker and no errors or warnings, all tests passed OK.

    I have PBX delivers audit switched to ON and checked all settings in the network and other tabs. If I made any changes, I restarted the services after any changes.

    I'm happy to provide the Wireshark capture and various log files if you are willing to look at it. Just let me know where I can send them.

    Thanks so far for your help.
     
  7. maatwerk3cx

    Joined:
    Aug 2, 2012
    Messages:
    6
    Likes Received:
    0
    ]

    I disabled the STUN server and entered my public IP.

    After restarting the 3CX services, on the first call, everything seemed to work OK. On subsquent calls, audio was lost after a few seconds. Very strange. Any ideas?

    Is there any more information about the error with STUN on 64-bit OS or an indication of when it will be fixed?

    Thanks.
     
  8. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    What type of firewall/router?

    You may need to enable keep alives as soem firewalls will open the port for only a limited time.
     
  9. maatwerk3cx

    Joined:
    Aug 2, 2012
    Messages:
    6
    Likes Received:
    0
    I disabled the firewall so I guess the keep-alives are not necessary.

    3CX is on a dedicated server provided by a hosting provider (Memset.co.uk) so there are no restrictions on the router apart from what is on my Windows Firewall, which I temporarily disabled
     
  10. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    Perhaps, if the dedicated server is also presenting the public IP directly so that port forwarding is not needed, then I tend to agree. I had a Mikrotik router/firewall that I was using and I was setting up fax for a client. We kept getting the beginning of the T38 packets but after some 30 seconds or so, the stream stopped. We determined that even though the firewall was "reportedly off", the port forwarding aspect was handled differently. We ended up having to add a statement to the router to simply keep the port open all the time.

    If you have a fixed public IP, STUN is not normally necessary. Get wireshark from the web and install and set to monitor your local 3CX server NIC. Make a call while wireshark is running and let it monitor the packets. When the issue presents itself and you can no longer hear the other side, then hang-up and stop the capture and then go to the "telephony" tab and then select "voip" calls. It will provide a listing of the calls that it saw and you can select the calls of interest and get a graphical display of what Ip addresses came into play along with the messaging. You can then highlight and select any one of the lines for closer examination to see what the message contents were.

    While not as deep, it may also be of benefit to post a verbose log of the entire call so that we can see it here on the forum and possibly see something. I also assume that you have entered your IP address in the Settings area under both STUN and Public IP and additionally, while not specifically stated, that you are indeed running V11, given the interest in the 64 bit issue.
     
  11. maatwerk3cx

    Joined:
    Aug 2, 2012
    Messages:
    6
    Likes Received:
    0
    Thankyou for the feedback, this has really helped.

    I've turned off STUN, it simply wasn't working, perhaps it is a bug. I have a fixed public IP so I don't need it anyway.

    I've used WireShark (what a brilliant application) and using your suggestion, managed to identify the problem.

    The stream from the media server of Orbtalk to my 3CX server was dropping after a variable number of seconds. The stream from the 3CX server to Orbtalk was fine, no dropping.

    I turned off Windows 2008 firwall temporarily, just to be sure, and it made no difference, the same problem.

    As my server is hosted (by Memset), I don't have any control over the routers/firewalls further upstream. It's probably some keep-alive issue rather than the ports being blocked as I'm quite sure the provider allows all ports through.

    I'll contact them to see what they say but in the meantime, I installed the 3CX server on a local PC at my house (so no firewall/router issues). It worked fine. Obviously not a permanent solution but hopefully my provider can help me out.

    Thanks for all your help
     
Thread Status:
Not open for further replies.