No Audio until call answered (Outbound calls)

Discussion in '3CX Phone System - General' started by PIC421, Apr 23, 2010.

Thread Status:
Not open for further replies.
  1. PIC421

    Joined:
    Apr 30, 2009
    Messages:
    4
    Likes Received:
    1
    Hi,

    I have 2 remote sites, both using 3CX SIP Proxy (Version 8.0.9674), both experiencing the same issue. 3CX version of 8.0.10824.716. Phones are Snom 320's and Snom 360's.

    The issue is that when the phones are going via the 3CX SIP Proxy, there is no ringing sound being played on outbound calls. However, once the party being called answers, full 2-way audio is available.

    We also have a VPN running to the site hosting the 3CX system. When the phones run over the VPN, i.e., no proxy, normal ring tone on outbound calls is acheived.

    Due to poor quality over the VPN I would prefer to use the proxy, but need to resolve the outbound ring tone issue.

    Does anyone have any ideas?

    Many thanks, David
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    Did you set an ip address or FQDN as the PBX IP on the SIP proxy manager?

    In the 3CX management console > Settings > advanced what did you set your Local SIP domain?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. PIC421

    Joined:
    Apr 30, 2009
    Messages:
    4
    Likes Received:
    1
    Hi Mark,

    PBX IP is set as an IP (203.19.70.193) in the SIP Proxy.

    3CX management console > Settings > advanced > Local SIP domain is set as '3cx.propertyit.com.au'

    Should these be aligned?

    Cheers
    David
     
  4. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Unless this resolved to the internal ip of your PBX then yes it needs to be changed to the internal IP of your PBX
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. PIC421

    Joined:
    Apr 30, 2009
    Messages:
    4
    Likes Received:
    1
    I've confirmed that the internal SIP domain of '3cx.propertyit.com.au' does resolve to the internal IP of the 3CX system.

    I did however change to '3cx.propertyit.local' to avoid any confusion - this has had no impact.

    I still have no outbound ring tone until connection.

    I have discovered that this only impacts external calls through a VoIP provider - internal calls - even other remote sites are ok.

    Did you have any other ideas that I could try?
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,868
    Likes Received:
    304
    Someone else had a similar problem a few months back...http://www.3cx.com/forums/no-ringback-tone-dialling-external-numbers-13513.html
     
  7. bullan

    Joined:
    Apr 25, 2010
    Messages:
    21
    Likes Received:
    0
    I'm experimenting the same problems.
    I have no ringback for the outbound calls (3 different providers)

    Internal calls are ok, ringback is audible.

    Did someone manage to correct this? Where can be? Firewall? NAT? settings?

    Edit:

    did some more testing: I'm using grandstream286, eybeam and 3cx softphone

    ringback is audible on 3cx softphone but not on HT286 and neither on eyebeam. Internal calls ok between extensions.
    can anyone debug this, or can we replicate the 3cxsoftphone settings on HT286 and Eybeam?
     
  8. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    I have checked with development, and this is a known issue with the the tunnel proxy manager at this point. We are working on a fix currently, Kindly keep an eye on the release logs of the latest builds so you may identify when the fix is released.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. bullan

    Joined:
    Apr 25, 2010
    Messages:
    21
    Likes Received:
    0
    Actually I don't use tunnels
    all extensions are on the same local network
     
  10. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Can you try the latest sip proxy manager

    http://www.3cx.com/downloads/3CXSIPProxyManager9.msi

    U need to use PBX v9 for this
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. brianp

    Joined:
    Aug 6, 2008
    Messages:
    45
    Likes Received:
    0
    we had the same issue on phone system 8 with corresponding SIP Proxy Manager. Upgraded to phone system 9 and SIP Proxy Manager 9 and that fixed it. Thank you!
     
  12. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Thanks for the update.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. stuart.rendall

    Joined:
    May 26, 2010
    Messages:
    25
    Likes Received:
    0
    The boss here complains of this and similar silences regularly.

    However, unhelpfully, I am unable to replicate the problem consistently, if at all.

    What adds to the problem is that there is always at least a couple of positive ring tones before hearing the outcome of the call e.g. busy, unobtainable, etc. The 'suppress early media' option in the softphone has no effect.

    Whilst writing this I may have found the problem.

    Making a phone call via 3CX, a Patton 4638 then ISDN to the British Telecom network:

    If typing a number on the softphone by hand, you miss the last digit, and then try to connect the call, you hear a couple of positive rings then complete silence. It would seem the numbers have been passed to the local exchange and it is waiting for the concluding digit before connecting the call. Additional digits can then be added during the silence and the call connected.

    In this case the ring generated by the softphone is very misleading, as is the 'screen' reporting the call as connected, even though the exchange is waiting for more digits before placing the call.

    Can the softphone gererate more useful messages as to the progress of the call initiating?
     
  14. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Yes we are going to change this and show ringing during early media.
    If you wish to try this, send me an email nb@3cx.com and I will send you a patch for you to test. The more exposure we get in different telecoms the better.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. stuart.rendall

    Joined:
    May 26, 2010
    Messages:
    25
    Likes Received:
    0
    The patch may have more functionality, but I don't see that displaying 'ringing' whilst the exchange is silent and waiting for additional digits is any more helpful.
    I am also wondering if my interpretation and use of the 'suppress early media' option is correct.
     
  16. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    But this is a different case.

    The exchange is silent - it is waiting for you to enter digits - What do you expect to see there?
    In this case it should be connected.
    give me this number that you are dialing let me see what it is.

    Early media is not a connected call - it is audio delivered while in ringing stage. At that point, the call is not established. So that is still a call progress area - call is still being established.

    The suppress early media option removes the audio you hear. Suppresses it. Maybe this is why you hear blank because you are suppressing it. Leave it on to see what is happening and try again.

    Also this is ia 3CXPhone related issue and has nothing to do with this post. Maybe you should consider going on the 3CXPhone forum section.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.