No caller ID from Wellgate 2540

Discussion in '3CX Phone System - General' started by wreynolds@rrwds.net, Feb 28, 2018.

Thread Status:
Not open for further replies.
  1. wreynolds@rrwds.net

    Joined:
    Jun 6, 2015
    Messages:
    2
    Likes Received:
    0
    So I have tried and yes googled to get the answer. I have a customer that is using a Wellgate 2540 for FXO PSTN lines and everything is working except incoming Caller ID is not showing up.

    I tried to edit the Outgoing Caller ID setting for display name to PSTN Caller Name but the gateway does nothing when I click Apply. It just sits there after I change the display name to PSTN Caller Name from the drop down. If I click a different menu option or back and then go back in to the SIP trunk settings its back to the NONE setting for display name.

    How do I get this gateway to change? Nothing I have done seems to apply a setting change and the customer is getting annoyed very quick that they no longer have any Caller ID after I switched them to 3CX.
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    Am a little confused as you mention incoming CID, but then indicate editing the outgoing CID. I am guessing you really meant incoming?

    In any event, you seem to suggest that CID and CNam were showing up before the change to 3CX. If so, then it may be nothing more than doing a capture of an incoming call and then examining the SIP headers for the desired info and then modifying the inbound parameters on the 3CX trunk for the Wellgate to match what the messaging provided.
     
  3. wreynolds@rrwds.net

    Joined:
    Jun 6, 2015
    Messages:
    2
    Likes Received:
    0
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    I still have the same questions:
    1. Was Cnam passing to the other system? If so, then it may mean that what you are trying to change is not (visually) taking as it is already implemented and what you see if simply a default setting on the web page which is likely a bug in the pages, but not in the desired operation. Otherwise, perhaps a factory reset is in order and then follow - https://www.3cx.com/voip-gateways/welltech-wellgate-2540/

    2. Did you mean incoming when you indicated outgoing?
    3. Have you confirmed that Cnam is being sent by the provider by using a analog phone with display?
    4. You are running the firmware as suggested in the other post?
    5. Have you done a capture to see if the Cnam info is in the SIP trace?

    The port you refer to is 2 years old. In looking at the firmware release notes, the Cnam issue was addressed in version wg25.4.02a.bin, but there have been a couple of releases since then to include the one mentioned in the 3CX guide on how to provision (above). The latest release is 4.02d and reportedly corrects:
    1. Fixed sometimes FXO will sending 2 times invite when have an incoming call from PSTN and FXO line setting incoming call handle configured to hotline mode / PSTN Answer Ring Count set to 1.
     
Thread Status:
Not open for further replies.