No incoming calls with Skype Connect -- still unsolved

Discussion in '3CX Phone System - General' started by luisalonsoramos, Sep 22, 2011.

Thread Status:
Not open for further replies.
  1. luisalonsoramos

    Joined:
    Apr 15, 2011
    Messages:
    35
    Likes Received:
    0
    Hi all,

    I recently signed up for Skype Manager, and added a SIP profile with an online number.

    I configured the VoIP provider in 3CX, and it worked fine... mostly.

    * 3CX registers with Skype
    * If I make outbound calls from an extension, the outbound rule routes it to Skype and my US cellphone rings with the caller ID of my Skype online number
    * However, if I dial from my cell phone to my online number, 3CX never sees the call.

    I tried connecting the softphone on my 3CX server to Skype and I get the same behaviour. I tried connecting a softphone on another server (that runs a separate 3CX installation) and the softphone receives the incoming call.

    So, it seems it is a firewall issue.

    By default 3CX uses ports 9000-9049 for RTP, but I changed the configuration in 3CX and my Grandstream gateway to use 8000-8020.

    I have opened ports 5060 UDP/TCP, 5090 UDP/TCP, and 8000-8020 UDP as the Skype guide says.

    Do you know if I need to open any other ports for the softphone to receive calls from Skype Connect? I checked the other firewall (where it worked) and apparently not.

    Do you have any other idea of what I could check?

    Thanks!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. intelligent7

    Joined:
    Mar 24, 2011
    Messages:
    6
    Likes Received:
    0
    Re: No incoming calls with Skype Connect

    I'm experiencing the same issue. Since your original post is about 6 months old, I'm assuming you resolved your issue. If so, could you tell me how? My issue is not firewall-related as I see the inbound call on the server log, but it's failing there.

    If I don't find a solution in another post, I'll return here and post all the details.

    Thanks,

    Blake
     
  3. luisalonsoramos

    Joined:
    Apr 15, 2011
    Messages:
    35
    Likes Received:
    0
    Re: No incoming calls with Skype Connect

    Hi Blake,

    No, I have not solved the issue. The post is almost a month old, and I have been out of the country since then. But here is more information:

    * My 3CX server is inside a network that has a Cradlepoint router.
    * That Cradlepoint router is inside a network with a Fortinet router, which in turn is connected to the internet.

    I am thinking the problem lies with the configuration of the Fortinet router, rather than my internal Cradlepoint.

    I am waiting until I get back home to take a look at it (and that is next week), so I'll let you know when I solve it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. intelligent7

    Joined:
    Mar 24, 2011
    Messages:
    6
    Likes Received:
    0
    Re: No incoming calls with Skype Connect

    Thanks... I was trying to edit my post to correct the "6 months" but couldn't submit the edit...

    I had a support chat w/Skype today and we determined that Skype is indeed delivering the call to the 3CX PBX; however, I received an error in my server log (I'll skip the details for now, because I'm still in gathering data) that, on the surface, looks like I may not have configured the inbound parameters correctly. Outbound calls through the SIP trunk work great, just not the inbound.

    I'll post back to this thread if I find anything interesting or useful.

    Blake
     
  5. luisalonsoramos

    Joined:
    Apr 15, 2011
    Messages:
    35
    Likes Received:
    0
    Re: No incoming calls with Skype Connect

    Yeah, I thought first that something with Skype was bad, but when I configured the softphone in another server (with a separate 3CX installation) and it worked, I found out that it was something with the firewalls on my side.

    I was not getting anything in the 3CX log, so the call never made it to the PBX.

    Sure, keep me posted if you find something. Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Roshen

    Joined:
    Jan 16, 2009
    Messages:
    35
    Likes Received:
    0
    Re: No incoming calls with Skype Connect

    Another month on and i have the same issue :). has either of you had any luck with this one?

    I have noticed that an outbound call works fine (From my 3cx ext to my mobile), but if i hang up the call from my mobile the call does not end, if i hang up the call from my 3cx extension the call ends OK

    I suspect this is a firewall issue, I use a D-Link DFL-210 firewall/router, is there anybody who can help me out with the firewall config?

    -Roshen
     
  7. 3cx

    3cx

    Joined:
    Mar 24, 2008
    Messages:
    24
    Likes Received:
    0
    Re: No incoming calls with Skype Connect

    Do a firewall checker:

    http://www.3cx.com/blog/docs/firewall-checker/

    and take it from there
     
  8. luisalonsoramos

    Joined:
    Apr 15, 2011
    Messages:
    35
    Likes Received:
    0
    Re: No incoming calls with Skype Connect

    Hello everybody,

    I have been playing with this issue the last 4 hours and I made a big advance (just not there yet). It was actually a firewall issue, and it ended up like this:

    * Ports 5060 (TCP/UDP), 5090 (TCP/UDP), 3478 (TCP/UDP), 8000-8049 (UDP).
    * I turned on SIP ALG (application level gateway), even though I read several times that I should turn it off.

    It now clears all the firewalls (there are two NAT routers and the server's firewall between 3CX and the internet).

    But I have one little problem: If I connect the 3CXPhone in my server directly to Skype, it now receives calls perfectly (it didn't work previously on my server, but it did on another server with a different internet connection). But if I turn the softphone off and immediately turn the 3CX PBX on (on the same sever), the PBX never sees the call.

    Again, outgoing calls have always worked perfectly, from everywhere.

    Any ideas?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Have you run the firewall checker ?
    If so, what is the result ?

    The problem you are complaining is typical networking (NAT / firewall) issue, not a PBX problem.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. luisalonsoramos

    Joined:
    Apr 15, 2011
    Messages:
    35
    Likes Received:
    0
    Yes, I did. Everything was OK, I passed all of the four tests (in the 3CX Firewall Checker).

    However, I tried http://tools.voxygen.co.uk/ which Skype recommended and it didn't pass the RTP tests, not even for one channel, even if I know ports 8000-8049 are open (I have checked them many times).

    But how can it be a firewall problem if the 3CXPhone receives the calls when connected directly to Skype (sip.skype.com and my authentication details), but the PBX in the same server doesn't?

    Remember the other server where the softphone received Skype Connect calls from the beginning? I tried setting up that PBX to use my Skype Connect account, and it also doesn't receive calls.

    So, I have two servers in which 3CXPhone connected directly to Skype Connect receives calls, but the PBX doesn't.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    The application exit code from firewall checker should be '0'. Make sure.
    Why are you using ports 8000 - 8049, instead of 9000 - 9049, which are default for 3CX ?
    If you still need to use custom ports, make sure you changed them in 3CX server.

    Have you set correctly port forwarding to 3cx server in your router (i.e. public_address:port to internal_address:port) ?
    The last is requirement for incoming calls from provider (without port forwarding you can still make outgoing call).
    Still it looks like a firewall / NAT problem.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. luisalonsoramos

    Joined:
    Apr 15, 2011
    Messages:
    35
    Likes Received:
    0
    I am using ports 8xxx instead of 9xxx because somewhere I read that Skype uses those ports. I changed them in 3CX Settings, in my FXO gateway (a Grandstream), and of course in my firewalls.

    I just ran the firewall checker again, and these are the results:

    ======
    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.

    <13:57:29>: Phase 1, checking servers connection, please wait...
    <13:57:31>: Stun Checker service is reachable. Phase 1 check passed.
    <13:57:31>: Phase 2a, Check Port Forwarding to UDP SIP port, please wait...
    <13:57:33>: UDP SIP Port is set to 5060. Response received correctly with no translation. Phase 2a check passed.

    <13:57:33>: Phase 2b. Check Port Forwarding to TCP SIP port, please wait...
    <13:57:34>: TCP SIP Port is set to 5060. Response received correctly with no translation. Phase 2b check passed.

    <13:57:34>: Phase 3. Check Port Forwarding to TCP Tunnel port, please wait...
    <13:57:34>: TCP TUNNEL Port is set to 5090. Response received correctly with no translation. Phase 3 check passed.

    <13:57:34>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <13:57:40>: UDP RTP Port 8000. Response received correctly with no translation. Phase 4-01 check passed.
    <13:57:40>: UDP RTP Port 8001. Response received correctly with no translation. Phase 4-02 check passed.
    ... all passed here ...
    <13:57:40>: UDP RTP Port 8049. Response received correctly with no translation. Phase 4-50 check passed.


    Application exit code is 0
    ======

    Since 3CXPhone receives calls correctly, it can be a firewall issue only if the PBX requires more ports than the softphone to use Skype Connect.

    I cannot easily set my server as DMZ, but I'll try with the other server I have been testing on, and let you know if I find something.

    Thanks for your time, I really appreciate it!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Stick to default ports (I have Skype trunk working so !) and make sure port mapping (forwarding) is correct. You mentioned something like your 3CX server being behind a double NAT (2 routers). It is something wrong with your setup. The 3CX softphone is obviously opening the firewall, so you make and receive calls from Skype, while the 3CX server relies on correct router configuration. To be sure about this, try running wireshark™, capture and analyze the traffic.
    I still don't think the problem is with your your 3CX server.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    1. Even Skype uses these ports, this still doesn't mean the 3CX server should use them (however, this is not a problem). My setup includes default ports and mapping, and Skype SIP trunk is working fine.

    2. What is the relationship of your FXO gateway to Skype and 3CX ? Such gateways are used for PSTN lines, which is not the case.

    If I'm understanding you correctly, there is something wrong in your concept (especially the gateway).

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. luisalonsoramos

    Joined:
    Apr 15, 2011
    Messages:
    35
    Likes Received:
    0
    Hello!

    I haven't tested the default ports or other things, since I have to wait for the weekend to bring down the phone system, but I'll update you when I do.

    My office is a small office (in Mexico) where I have three PSTN lines (actually one, and the other two are extensions from an analog PBX next door). These are working fine.

    I am setting up a branch office in the US, and I hired Skype SIP channel with a US number. That is the one with which I am having problems.

    Thanks again for all your time! :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Revoke everything to default settings (reinstall 3CX). You need to map (route) external address:ports to internal address:ports of 3CX in your router to use any VoIP provider according 3CX guidelines. Run firewall checker. You must have exit code = 0.

    Nothing special about SIP trunk from Skype -- just set it using the Skype for SIP wizard in Providers settings page. Keep it simple.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    try listing your Skype Online Number as a DDI within the provider settings. or watch our Youtube Video http://www.youtube.com/itcommunicationsltd#p/a/u/0/76Q6j1E_JzE
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.