No Incoming Calls

Discussion in '3CX Phone System - General' started by jmason, Feb 1, 2011.

Thread Status:
Not open for further replies.
  1. jmason

    Joined:
    Feb 1, 2011
    Messages:
    3
    Likes Received:
    0
    I had downloaded and installed the 3CX Free edition to evaluate it with my new Cisco WIP310 and inPhonex account.

    After spending a few hours working through all the nuances of each piece of the puzzle, and getting the phone to make and receive calls, I decided to enter the License Key that 3CX emailed me which upgrades the Free version to the full version but limits simultaneous calls to 2.

    As soon as I did this, all of a sudden my WIP310 doesnt ring anymore. I can place outgoing calls with no problem but incoming calls no longer work. The funny thing is that if I click the "Free Edition" button to downgrade the software it starts working again. Kind of funny that the "Free" version seems to work better than the licensed one...

    Any help would be greatly appreciated.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,568
    Likes Received:
    246
    It really shouldn't make any difference in that regard. What does the 3CX log show when you try calling the Linksys, and it fails?
     
  3. jmason

    Joined:
    Feb 1, 2011
    Messages:
    3
    Likes Received:
    0
    That is one thing that is making this trouble shooting so difficult. It is not creating any log entries when I click on "Server Activity Log". Everything "looks" normal and seems to be operating but the phone wont ring and it wont go to voicemail either.

    Cant understand why it starts working again if I downgrade to the Free edition.

    Is there a specific provision XML that I should be using for the Cisco WIP310 because I read some posts and followed what another user did and selected the "Linksys SPA-962" model.. Is there a setting in the configuration of the phone itself that could be causing the issue?
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,568
    Likes Received:
    246
    There should be some logs in there, even if just to show the system starting up. You can change the logging levels in Settings/Advanced/logging Level, but even at Low, you should see some logs. You can go into the 3CX menu, just below the Server Activity Log, and have a look at Services Status, to be sure that all services have started. If they haven't, then try staring them manually.

    Sorry, I can't help you there, have always provisioned devices manually. When using the Demo Key, does the WIP show that it is registered?
     
  5. jmason

    Joined:
    Feb 1, 2011
    Messages:
    3
    Likes Received:
    0
    Thanks for the replies.. I figured it out this morning. It is still a very strange behaviour but here is what my situation was:

    - When I finished installing the 3CX server and registered my phone it would make OUTGOING calls but it would not ring when trying to take INCOMING. I ended up having to create an INBOUND rule that said to route all calls to my extension in order for it to ring.

    - As soon as I switched to the license key, it would stop ringing. This morning, I deleted the INBOUND rule and it starting ringing again.

    I have no idea why it is working this way, but, this has been my experience with the setup so far.
     
  6. jaruf

    Joined:
    Feb 8, 2011
    Messages:
    1
    Likes Received:
    0
    Welcome to the Club ;-) at this moment i'm using it just for outside callings

    I've been fighting with it with no success . No support from inphonex either

    Check your customer control panel (inphonex) and see how many times the Virtual number is registered , I have more than 6 registrations with the same number

    I opened ports 5060 (both) and 9000 9049 (udp)

    I you find a solution i'll appreciate it
     
Thread Status:
Not open for further replies.