No incoming line on Linksys SPA-3102

Discussion in '3CX Phone System - General' started by Tom, Jan 14, 2010.

Thread Status:
Not open for further replies.
  1. Tom

    Tom

    Joined:
    Mar 6, 2007
    Messages:
    10
    Likes Received:
    0
    Hello,

    I have configured an SPA-3102 according to the user manual.
    I am able to make outbound calls without any problems.
    Incoming calls however don't work.

    I can see the following in the Server Activity Log:
    21:49:31.242 [CM102001]: Authentication failed for SipReq: INVITE <10001@192.168.100.20 tid=-4f432ca3 cseq=INVITE contact=0477272523@192.168.100.29:5062 / 102 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    21:49:31.242 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:%3C10001@192.168.100.20 SIP/2.0
    Via: SIP/2.0/UDP 192.168.100.29:5062;branch=z9hG4bK-4f432ca3
    Max-Forwards: 70
    Contact: "SPA_3102"<sip:0477272523@192.168.100.29:5062>
    To: <sip:%3C10001@192.168.100.20>
    From: "SPA_3102"<sip:0477272523@192.168.100.20>;tag=cebfb2d5d94016fbo1
    Call-ID: eb79bb5d-23b66813@192.168.100.29
    CSeq: 102 INVITE
    Expires: 240
    Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
    Proxy-Authorization: Digest username="10001",realm="3CXPhoneSystem",nonce="414d535c0160145b76:a8a92a3aa6443f4575966ed95e09a6bc",uri="sip:<10001@192.168.100.20",algorithm=MD5,response="bbc5d95f2b78c40fb936bc46028cd1f2"
    Supported: x-sipura, replaces
    User-Agent: Linksys/SPA3102-5.1.10(GW)
    Content-Length: 0
    Remote-Party-ID: SPA_3102 <sip:0477272523@192.168.100.20>;screen=yes;party=calling

    21:49:31.242 [CM302002]: Authentication failed due to unidentified source of: SipReq: INVITE <10001@192.168.100.20 tid=-4f432ca3 cseq=INVITE contact=0477272523@192.168.100.29:5062 / 102 from(wire)
    21:49:31.132 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:%3C10001@192.168.100.20 SIP/2.0
    Via: SIP/2.0/UDP 192.168.100.29:5062;branch=z9hG4bK-3f56b78b
    Max-Forwards: 70
    Contact: "SPA_3102"<sip:0477272523@192.168.100.29:5062>
    To: <sip:%3C10001@192.168.100.20>
    From: "SPA_3102"<sip:0477272523@192.168.100.20>;tag=cebfb2d5d94016fbo1
    Call-ID: eb79bb5d-23b66813@192.168.100.29
    CSeq: 101 INVITE
    Expires: 240
    Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
    Supported: x-sipura, replaces
    User-Agent: Linksys/SPA3102-5.1.10(GW)
    Content-Length: 0
    Remote-Party-ID: SPA_3102 <sip:0477272523@192.168.100.20>;screen=yes;party=calling

    21:49:31.117 [CM302001]: Authorization system can not identify source of: SipReq: INVITE <10001@192.168.100.20 tid=-3f56b78b cseq=INVITE contact=0477272523@192.168.100.29:5062 / 101 from(wire)

    Can someone help me with this please?
    Thanks,
    Tom
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Well, this line sort of says that you'd better double check your settings, one end doesn't match the other.
     
  3. Tom

    Tom

    Joined:
    Mar 6, 2007
    Messages:
    10
    Likes Received:
    0
    I've checked the authentication id and password a couple of times and they are exactly as entered in 3cx. Furthermore I see that the line is successfully registered and I'm able to make outbound calls over that extension.

    Any more ideas?

    Thanks,
    Tom
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    It might be registering but when you go to place a call it doesn't seem too be happy.
    What outbound calls can you make? Over the 3102, or you just mean from extension to extension?

    This is from the 3CX SPA-3102 setup page:

    The Subscriber Information section represents the PSTN line connected to the gateway. Configure the line as follows:
    a. The "Display Name" should have a name assigned to it. Choose a display name that will not match a possible number; it also must NOT be blank. If this field is blank, or matches the caller’s number, the device will operate in 2-stage dialing mode. Choosing an alphanumeric Display name is a safe choice. E.g.: "SPA-3102" or "Outside Line".
    b. In the "User ID" field, enter a name for the line.
    c. Set the "Use Auth ID" field to "yes".
    d. In the "Authentication ID" and "Password" fields, enter the ID and Password that you entered for the line in the 3CX Phone System Management Console. These fields must match the ID and password set for the line in the 3CX Phone System Management Console.
     
  5. Tom

    Tom

    Joined:
    Mar 6, 2007
    Messages:
    10
    Likes Received:
    0
    Thanks for the replies.

    I am able to make outbound calls over the spa-3102.

    The display name is spa-3102, the user id and authentication id are both 10001, and the pwd is correctly entered.

    Any more ideas?

    Thanks
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Did you change the port number for the FXO port on the 3102 from the default of 5061 to the 3CX setting of 5062?
     
  7. Tom

    Tom

    Joined:
    Mar 6, 2007
    Messages:
    10
    Likes Received:
    0
    yes, I did.
     
  8. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Source identification rules.

    The destination is specified as "<10001". Is it correct?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Tom

    Tom

    Joined:
    Mar 6, 2007
    Messages:
    10
    Likes Received:
    0
    That is correct,I registered the spa-3102 as 10001. there is also a voip line registered under 10000.
     
  10. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    No, there is <10001!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Is it datafilled exactly as (S0<:10001>) in the 3102 dialplan? < in hex is 3c so the : is probably missing in your datafill, it can be the tiniest error...
     
  12. Tom

    Tom

    Joined:
    Mar 6, 2007
    Messages:
    10
    Likes Received:
    0
    Dial plan 8 was set to (S0<:10001>)

    I have now re-flashed the SPA-3102, reset to factory defaults, re-entered all settings again and now it works.
    Probably the device got stuck somewhere...

    Everyone thanks for the help!

    Tom
     
  13. paperboy

    Joined:
    Jan 6, 2013
    Messages:
    1
    Likes Received:
    0
    I know this is an old thread, but I had the same (or at least a similar) problem, which after a lot of hair tearing I seem to have solved. The 3cx guide seems to have two errors and I thought it worth posting here

    First (picked up elsewhere) PSTN Caller ID should be blank, not "*".

    Second, set "PSTN CID For VoIP CID" to No. 3CX was trying to authenticate against the PSTN caller ID rather than against the gateway id. This change enabled the call to go through, although we have now lost the caller id. Not sure how to get that back, but at least its working.

    It's a great pity 3cx haven't updated their guide as it would save newcomers like me a huge amount of time!

    Steve.
     
  14. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    I agree with your first point, and a while back asked 3CX to make a note in the set-up guide regarding the *, as it was causing some grief. I've never used it myself.

    I disagree with your second point. I have always set PSTN CID For VoIP CID, to Yes, and have never has any issues. Caller ID comes through fine. In fact, I'm not sure what caller ID has to do with authentication.

    If setting to Yes, does not work for you (and I'm not sure where in the world you are located, or if that makes a difference), then you may want to review your other settings, something else is not right.

    If you continue to have issues, post the PSTN tab (X out anything security sensitive), and we can go over the settings.
     
  15. erjavi

    Joined:
    Feb 3, 2013
    Messages:
    1
    Likes Received:
    0
    My English is not very good, but I've resolved as follows:

    In the spa3102 LINE1 tab the option "SIP Remote-Party-ID:" I've marked as NO

    From that moment and I can make calls from the extension of the SPA3102 and gives no error INVITED.

    Greetings.
     
  16. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    This is to enable using the Remote Party ID header rather than the From Header.
    The factory default for that setting is YES, and I've never had a reason to change it, so, I'm not sure what is happening in your case.
    Is the line being used as a 3CX extension? Local, or remote?
     
Thread Status:
Not open for further replies.