Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

No outbound calls

Discussion in '3CX Phone System - General' started by gschwab, Jun 30, 2016.

Thread Status:
Not open for further replies.
  1. gschwab

    gschwab New Member

    Joined:
    Mar 21, 2012
    Messages:
    131
    Likes Received:
    0
    Running 3CX V14 with SP3. system has been working fine until yesterday AM, outbound calls fail with "internal server error"
    I found no obvious issues on my end and firewall checker still passes all tests. Contacted my SIP trunk provider and they say they see the invite from my system but they receive no response to the challenge sent from their system, they think that Frontier (we were with Verizon Fios, now Frontier) my be blocking port 5060. I have tried changing the port but no matter what port I try it will not pass firewall checker Test2. Does 3CX not allow us to change the port?
    Inbound calls working fine.

    Thanks for any suggestions.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,380
    Likes Received:
    84
    You can change the SIP Port from Settings -> Network, but as you have changed ISPs I assume the Public IP has changed. Do you have the new static Public IP set in Settings -> Network -> Public IP tab?

    If not change it there and restart all services for the change to take effect.

    Also check in the Provider settings in the "Advanced" tab in case you have overridden the default public IP there and also make the necessary changes if needed.
     
  3. gschwab

    gschwab New Member

    Joined:
    Mar 21, 2012
    Messages:
    131
    Likes Received:
    0
    Thanks for the reply, yes public IP is set correctly and my inbound calls work, my big issue is that I can't get 3CX to pass the firewall checker Test 2, one to one forwarding. I change the port forwarding in my router from 5060 to say 5070, I change the port in 3CX Settings -> Network, reboot the router, restart all services and it fails 5070 Test 2 every time, I'm clueless.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,380
    Likes Received:
    84
    What exactly is the message in the Firewall Checker for 5070?
     
  5. gschwab

    gschwab New Member

    Joined:
    Mar 21, 2012
    Messages:
    131
    Likes Received:
    0
    I get
    Test1 reachability test ... resolved public IP: XX.XXX.XXX.27 (i masked this, it DOES show my actual public IP address)

    Test2 one on one port forwarding FAILED...
    no response received or port mapping is closed. firewall check failed, this configuration is not supported.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,575
    Likes Received:
    305
    Windows firewall didn't accidentally get turned on?
    try a reboot?
    my system wasn't passing multicast audio for paging. a reboot fixed it.
    every once in a while I see some strange behavior.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,380
    Likes Received:
    84
    To understand what Test 1 and Test 2 are, as well as the reasons they may fail, there is a very detailed (and slightly technical) article about it here:
    http://www.3cx.com/blog/docs/firewall-voip-rules-check/

    Hopefully this will help understand and troubleshoot the issue you are having.
     
Thread Status:
Not open for further replies.