Solved No outbound calls

Discussion in '3CX Phone System - General' started by vanick, Jan 20, 2018.

Thread Status:
Not open for further replies.
  1. vanick

    Joined:
    Feb 10, 2012
    Messages:
    8
    Likes Received:
    0
    Hi all,

    I set up a SBC at a new site on a Pi3 recently, and tested it successfully with a Yealink T42S. It auto provisioned and can make and receive internal and external calls. BLFs all work fine.

    This morning I tried to provision a Yealink W56P DECT phone on the same network. I followed the official 3CX instructions for doing so in a SBC environment, and it all seemed to provision correctly.

    However, when I tested it, I found the DECT handset can receive incoming calls just fine, but all outbound calls (internal and external) fail with a "Global error" message. I checked the logs and found this:

    Warning: 499 ip-xxxxxxxx "Caller is forbidden"

    I've checked and double checked and can't find any setting blocking outbound calls from this handset/extension.

    Any suggestions on what the cause may be please?

    Thanks,
    Adriaan

    PS: Base FW is 25.80.0.15, Handset FW is 61.80.0.15
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,748
    Likes Received:
    285
    You allowed external calls in the extension settings, nothing else that might affect outgoing calls in those settings? Since the other extension works, I would compare an outgoing 3CX Activity Log from the working set and one with the non-working set. Other than the forbidden message are there any other glaring differences? Same digits sent, IP's look to be correct?
     
  3. vanick

    Joined:
    Feb 10, 2012
    Messages:
    8
    Likes Received:
    0
    Did a Wireshark capture, and I can see there is a difference in the "From" header. The successful calls use the domain name, whereas the rejected calls use the remote site's IP address:

    Successful calls: ""T42S Handset" <sip:111@mydomain.3cx.com:5060"
    Rejected calls: ""W56P DECT Phone" <sip:112@192.168.1.5:5060"

    To fix this I'm guessing some fiddling with the provisioning templates will be required?

    Thanks,
    Adriaan
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,748
    Likes Received:
    285
    I'm surprised to see a local IP at all. Is that the local IP of the DECT phone. or the local IP of the 3CX server?
     
  5. vanick

    Joined:
    Feb 10, 2012
    Messages:
    8
    Likes Received:
    0
    It is the local IP of the SBC
     
  6. vanick

    Joined:
    Feb 10, 2012
    Messages:
    8
    Likes Received:
    0
    Issue resolved: during the setup of the SBC, it asks for the IP address of the Remote PBX. Using the internal IP instead of the Public IP fixed the problem.

    Thanks to Nikos at 3CX who came up with this solution.
     
  7. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Glad to see the issue has been resolved and thank you for sharing your solution
     
Thread Status:
Not open for further replies.