No outgoing calls possible, Grandstream gives 480 reason

Discussion in '3CX Phone System - General' started by redwood, Feb 20, 2008.

Thread Status:
Not open for further replies.
  1. redwood

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    I've used 3cx before and got some problems with it, so i've found the problems, reinstalled 3cx with the latest version and now i want to use it "live".
    But i'm running against a problem.
    Incoming calls works 100% fine, but when i try an outgoing call, nothing happens. No tone, nothing. When i look into the log it says the following:


    10:20:24.001 Call::Terminate [CM503008]: Call(10): Call is terminated
    10:20:10.079 CallLeg::eek:nFailure [CM503003]: Call(10): Call to sip:062110000@sip1.voipprovider.nl:5060 has failed; Cause: 408 Request Timeout; internal
    10:19:37.455 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(10): Calling: VoIPline:10000@[Dev:sip:31507115301@sip1.voipprovider.nl:5060, Dev:sip:31507115301@sip1.voipprovider.nl:5060, Dev:sip:31507115301@sip1.voipprovider.nl:5060]

    What could this be? (i've tried removing and reinstalling 3cx, but that not works)
    The firewall test says: Passed.
     
  2. Philco

    Philco Member

    Joined:
    Nov 10, 2007
    Messages:
    364
    Likes Received:
    0
    Hi Redwood, if all your lines are registering as I guess they are as incoming calls are getting through and you can make calls between extensions, then look at your outbound rules.

    Also, as a long shot and may sound obvious, your voip provider may require credit to make calls to numbers not in their 'net'.

    Phil
     
  3. redwood

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    Hey Phil.
    Thanks, but i don't think those cause the problems.

    The voipprovider i'm using doesn't need credit, and if i configure the account on a ip phone it works fine.
    Second, it all worked fine since i've reinstalled 3CX, probably i'm just missing some settings, but i can't find them.
    The settings for outbound rules are as follow:

    Calls to Numbers starting with (Prefix): 0
    Calls from extension(s): 10 (10 is registered, and working for incoming calls)
    Calls to Numbers with a length of: (blank)
    Route 1: my provider, strip digits: 0. prepend:(blank)

    Alex
     
  4. Philco

    Philco Member

    Joined:
    Nov 10, 2007
    Messages:
    364
    Likes Received:
    0
    Hi Redwood.

    Do you have any other rules in the list.

    Just as a matter of interest, try removing the calls from extensions in the outbound rules leaving just the prefix 0 and the strip 0 and preappend blank as you have at the moment.

    Now try the call.

    Phil
     
  5. redwood

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    Sorry, but also not working: got an verbose log maybe it helps?

    [CM503003]: Call(4): Call to sip:0621110000@sip1.myvoip.nl:5060 has failed; Cause: 408 Request Timeout; internal
    22:07:24.727 MediaServerReporting::SetRemoteParty [MS210002] C:5.2:Offer provided. Connection(transcoding mode): 82.73.4.181:9002(9003)
    22:07:24.524 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(5): Calling: VoIPline:10000@[Dev:sip:31507110000@sip1.myvoip.nl:5060, Dev:sip:31507110000@sip1.myvoip.nl:5060, Dev:sip:31507110000@sip1.myvoip.nl:5060, Dev:sip:31507110000@sip1.myvoip.nl:5060, Dev:sip:31507110000@sip1.belcentrale.nl:5060]
    22:07:24.524 CallCtrl::eek:nSelectRouteReq [CM503010]: Making route(s) to [sip:0621110000@192.168.138.1:5060]
    22:07:24.509 MediaServerReporting::SetRemoteParty [MS210000] C:5.1:Offer received. RTP connection: 127.0.0.1:42002(42003)
    22:07:24.509 CallLeg::setRemoteSdp Remote SDP is set for legC:5.1
    22:07:24.509 Extension::printEndpointInfo [CM505001]: Ext.10: Device info: Device Identified: [Man: 3CX Ltd.;Mod: 3CX VoIP Client;Rev: 1] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Phone v0.1] Transport: [sip:192.168.138.1:5060]
    22:07:24.493 CallCtrl::eek:nIncomingCall [CM503001]: Call(5): Incoming call from Ext.10 to [sip:0621117082@192.168.138.1:5060]
    22:07:24.477 CallLeg::eek:nNewCall [CM500002]: Info on incoming INVITE:
    INVITE sip:0621110000@192.168.138.1:5060 SIP/2.0
    Via: SIP/2.0/UDP 127.0.0.1:5070;branch=z9hG4bK-d87543-78588e2b9376c95c-1--d87543-;rport=5070;received=192.168.138.1
    Max-Forwards: 70
    Contact: [sip:10@127.0.0.1:5070]
    To: [sip:0621110000@192.168.138.1:5060]
    From: "3CXPhone"[sip:10@192.168.138.1:5060];tag=7174a32b
    Call-ID: OTk3YzhiM2ZjNGFlZjY1M2I0OGNkMjhmOWVkOWMyZDY.
    CSeq: 2 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, NOTIFY, REFER
    Proxy-Authorization: Digest username="10",realm="3CXPhoneSystem",nonce="12848015244:8a524d62302e9480d76d6ad23f14dc0f",uri="sip:0621110000@192.168.138.1:5060",response="777428b5284d539964a1a022971553c0",algorithm=MD5
    Supported: replaces
    User-Agent: 3CX Phone v0.1
    Content-Length: 0

    ps. the 0621110000 is the number of my cell phone i use to trie to make it work. and the 31507110000 is the voip nummer used. (due privacy these are not real numbers )
     
  6. Philco

    Philco Member

    Joined:
    Nov 10, 2007
    Messages:
    364
    Likes Received:
    0
    I have some strange encounteres with outbound rules with extensions and prefixes so thats why I suggested it.

    If the account works fine outside 3cx then its looking like the line configuration in 3cx.

    I'm not sure what your log is actually saying appart from the connection doesnt seem to be being directed through your provider correctly so it times out.


    Have you tried configuring the line using the minimal of settings, i.e., proxy address, proxy port, registration address and addrress, and left everything else as default appart from the account username and password of course.

    Phil
     
  7. redwood

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    Yes, that's how i've initialised it, only the proxy address, proxy port, registration address, Authentication ID and Authentication password.
    Maybe it's best to uninstall 3cx, remove every 3cx entry from the windows registry, and install it again. Do nothing special, but only 1 extension and 1 outbound rule.

    The strange part is that,the first time i've installed 3cx, i'm almost sure i did everything exactly the same as i did with this install. And that worked fine the first time. After that i've unistalled 3cx to get an fresh and up-2-date installation and now it won't work.
     
  8. Philco

    Philco Member

    Joined:
    Nov 10, 2007
    Messages:
    364
    Likes Received:
    0
    Its worryng that the reinstall seems to be a cure for problems, but that may be the cure too in your case, particularly if your configurations worked ok before.


    Phil
     
  9. redwood

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    One thing i've noticed after uninstalling is that the bin and data maps are not being deleted in any way! So i've done that manually right now.
    Ok.. that didn't work.

    I've uninstalled and after that manually deleted everything concerning 3cx from the server and the registry.
    Reinstalled 3cx. Made and extension (20). Add an voip account (only setting up the basics) And made the outbound rule.
    Connected the 3cx software phone (to be sure it's not my grandstream who's giving the problems). After this, incoming calls work fine, but outgoing calls still won't work.

    this is the log:
    23:41:22.870 Call::Terminate [CM503008]: Call(2): Call is terminated
    23:41:22.838 Call::RouteFailed [CM503014]: Call(2): Attempt to reach [sip:0621110000@192.168.138.1:5060] failed. Reason: No Answer
    23:41:22.838 CallLeg::eek:nFailure [CM503003]: Call(2): Call to sip:0621110000@sip1.voipprovider.nl:5060 has failed; Cause: 408 Request Timeout; internal
    23:40:50.557 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(2): Calling: VoIPline:10000@[Dev:sip:31507110000@sip1.voipprovider.nl:5060]
    23:40:50.526 CallCtrl::eek:nIncomingCall [CM503001]: Call(2): Incoming call from Ext.20 to [sip:0621110000@192.168.138.1:5060].

    What could be potential problems. All ports are opened in the router, and firewall gives ok status. Could it be something wrong with the installation, the FQDN setup it asks for?? I've entered our own sipserver adres (wich routes to back to the server)
     
  10. landfiets

    landfiets New Member

    Joined:
    Jul 17, 2007
    Messages:
    243
    Likes Received:
    0
    Hi mr. Rooibos ( I think you like tea? )

    What Windows version are you using. Are you using 2 NIC's on the same computer?
    Try your phone as an external extension at the neighbours.
    Sometimes that helps to find out where the problems are.
    Did you open on the local firewalls (so on local computers) the ports 7000-7499 ?
    Switch computer firewall off for a while. What did you fill out in the extension side.
    And maybe a very stupid question. Since you are testing do you have those providers also registered on a different phone to stay reached? I know with budgetphone you can register as much as you want, but some others only like you to register once with one phone or PBX
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. redwood

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
     
  12. redwood

    Joined:
    Jan 29, 2008
    Messages:
    20
    Likes Received:
    0
    I've tried everything all day long. Factory resetting my router, removing, rebooting and reinstalling 3cx,. Factory reset voip phone, reset the internet connection. but no solution :(
    Tomorrow i'll trie installing 3cx on another computer just to make sure it's not the server. But after this, i ain't going to find a solution...
     
Thread Status:
Not open for further replies.