No RTP Packets

Discussion in '3CX Phone System - General' started by Anonymous, Feb 22, 2010.

Thread Status:
Not open for further replies.
  1. Anonymous

    Anonymous Guest

    Hi,

    Had a previously running system running in house on a server with local phones.

    I have moved the install to a server in a datacentre and restored the config.

    Now i have gone through the config and i've run out of ideas. :cry:
    Ports are forwarded 5060, RTP 9000-9006 etc

    Remote ip range is 10.1.x.x
    Local 192.168.x.x

    The phone is registered with the server no problems, I can make a call to my number, the greeting then queue starts, the phone rings answer and silence.
    I can ring out but no sound, voicemail calls but not sound, all i can hear is the music on hold......

    I am using a linksys spa942 phone if that helps, thanks

    Alright problem being, in the logs, i can see No RTP packets with the local ip of my phone 192.168.x.x being no vpn 10.1.x.x can't talk to it.
    Question how do i get around this???? or make the phone use my external IP.

    FYI firewall logs are showing udp packets from rtp going to the 192.168 address as accepted so nothing is being blocked.
     
  2. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    If I understand you are doing Phone behind NAT to PBX behind different NAT. Make sure you have the NAT settings on the phone set correctly and also check to see if rport is enabled.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Anonymous

    Anonymous Guest

    Hi,

    Yes phone and pbx behind different nat.

    OK getting there slowly. FYI i can answer the call going to the mobile no problems so comes down to phone settings.

    Not sure what settings you mean see below, i have changed to this there is now audio but the caller can't be heard.

    NAT Mapping Enable: yes
    NAT Keep Alive Enable: yes
    Handle VIA received: yes Handle VIA rport: yes
    Insert VIA received: yes Insert VIA rport: yes

    its also showing the external ip now on the phone so getting there.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,754
    Likes Received:
    286
    Have you enabled STUN on the phone? That wouldn't have been needed previously when the phone and 3CX were on the same network.
     
  5. Anonymous

    Anonymous Guest


    Just enabled stun on the phone, these things are shocking for configuration.

    just an update, all parts of call is working, just the person calling in can't hear anything, i can hear them and also hear myself via my own phone :shock: has to be something in the phone i can't for the life of me work out what
     
  6. Anonymous

    Anonymous Guest

    Ok an update, the calls are coming in i have changed the lines to UDP instead of TCP and the voice is both ways. Next problem after doing this the music on hold won't work anymore, i have the external server ip in the MOH section, it just times out then drops the call. any ideas??

    i have stun turned on too stun.3cx.com
     
  7. Anonymous

    Anonymous Guest

    Anyone have any ideas on this?? the rest of the system has ben working fine since the changeover. just the hold music not working.

    The phone has the same setting as the voicemail and it is working ok.
     
Thread Status:
Not open for further replies.