No VM or Prompts - Driving me mad

Discussion in '3CX Phone System - General' started by JayUK, Jul 23, 2008.

Thread Status:
Not open for further replies.
  1. JayUK

    Joined:
    Jul 23, 2008
    Messages:
    4
    Likes Received:
    0
    Hi, I have been playing around with this software to become proficient with a view to offering it to clients as a business solution.
    I have installed it on my test server (2003 sp2) no problems all seems ok.. Can setup an extension and connect and old ATA which is also fine. I have created some voip providers and I can make and receive calls via the ATA through 3CX.
    Now my problems..
    Voice mail will not work at all, I have tried enable/disable, re-installing soft, resetting all settings from scratch many times.
    When I dial VM which is 99999 (using 5 digit ext.s have also tried 3 digit) it immediately gives me a long tone (dues to the system terminating the call.
    i get the following in the log..

    19:38:01.188 Call::Terminate [CM503008]: Call(9): Call is terminated
    19:38:01.168 Call::RouteFailed [CM503015]: Call(9): Attempt to reach [sip:999@192.168.1.222] failed. Reason: Not Found
    19:38:01.168 CallCtrl::eek:nSelectRouteReq [CM503014]: Call(9): No known route to target: [sip:999@192.168.1.222]
    19:38:01.168 CallCtrl::eek:nSelectRouteReq [CM503010]: Making route(s) to [sip:999@192.168.1.222]
    19:38:01.168 Extension::printEndpointInfo [CM505001]: Ext.10000: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [VOYAGER10V/2.16] Transport: [sip:192.168.1.222:5060]
    19:38:01.128 CallCtrl::eek:nIncomingCall [CM503001]: Call(9): Incoming call from Ext.10000 to [sip:999@192.168.1.222]

    It is as if the VM system is not setting up the VM extension? Or am I missing something silly?

    If it helps, below is a log of the system initialise..

    18:51:31.667 StunClient::eek:nInitTests [CM506001]: STUN request to resolve SIP external IP:port mapping is sent to STUN server 75.101.138.128:3478 over Transport 192.168.1.222:5060
    18:36:16.111 Call::Terminate [CM503008]: Call(2): Call is terminated
    18:36:16.101 Call::RouteFailed [CM503015]: Call(2): Attempt to reach [sip:999@192.168.1.222] failed. Reason: Not Found
    18:36:16.101 CallCtrl::eek:nSelectRouteReq [CM503014]: Call(2): No known route to target: [sip:999@192.168.1.222]
    18:36:16.041 CallCtrl::eek:nSelectRouteReq [CM503010]: Making route(s) to [sip:999@192.168.1.222]
    18:36:16.041 Extension::printEndpointInfo [CM505001]: Ext.10000: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [VOYAGER10V/2.16] Transport: [sip:192.168.1.222:5060]
    18:36:16.001 CallCtrl::eek:nIncomingCall [CM503001]: Call(2): Incoming call from Ext.10000 to [sip:999@192.168.1.222]
    18:35:59.176 Call::Terminate [CM503008]: Call(1): Call is terminated
    18:35:59.136 Call::RouteFailed [CM503015]: Call(1): Attempt to reach [sip:10000@192.168.1.222] failed. Reason: Not Registered
    18:35:59.116 Call::RouteFailed [CM503015]: Call(1): Attempt to reach [sip:10000@192.168.1.222] failed. Reason: Not Registered
    18:35:59.116 CallCtrl::eek:nRerouteReq [CM503016]: Call(1): Target is not registered: Ext:Ext.99999
    18:35:59.026 Call::RouteFailed [CM503015]: Call(1): Attempt to reach [sip:10000@192.168.1.222] failed. Reason: Busy
    18:35:59.026 CallCtrl::eek:nSelectRouteReq [CM503014]: Call(1): No known route to target: [sip:10000@192.168.1.222]
    18:35:58.996 CallCtrl::eek:nSelectRouteReq [CM503010]: Making route(s) to [sip:10000@192.168.1.222]
    18:35:58.956 Extension::printEndpointInfo [CM505001]: Ext.10000: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [VOYAGER10V/2.16] Transport: [sip:192.168.1.222:5060]
    18:35:57.844 CallCtrl::eek:nIncomingCall [CM503001]: Call(1): Incoming call from Ext.10000 to [sip:10000@192.168.1.222]
    18:31:32.803 FaxCfg::updateContact [CM504008]: Fax Service: registered as sip:88888@192.168.1.222:5060 with contact sip:88888@192.168.1.222:5100;user=phone
    18:31:32.182 ExtnCfg::updateContact [CM504001]: Ext.10000: new contact is registered. Contact(s): [sip:10000@192.168.1.122:5060/10000]
    18:31:31.441 StunClient::process [CM506002]: Resolved SIP external IP:port (81.109.64.155:5060) on Transport 192.168.1.222:5060
    18:31:31.251 StunClient::eek:nInitTests [CM506001]: STUN request to resolve SIP external IP:port mapping is sent to STUN server 75.101.138.128:3478 over Transport 192.168.1.222:5060
    18:31:29.378 ExtnCfg::updateContact [CM504001]: Ext.*1: new contact is registered. Contact(s): [sip:*1@127.0.0.1:40000;rinstance=5f08d00d68051901/*1]
    18:31:28.768 ExtnCfg::updateContact [CM504001]: Ext.*0: new contact is registered. Contact(s): [sip:*0@127.0.0.1:40000;rinstance=f55a01283b250629/*0]
    18:31:28.157 FaxCfg::updateContact [CM504009]: Fax Service: changed contact to sip:88888@192.168.1.222:5100;user=phone
    18:31:25.232 CallMgr::eek:nAddIPs IP(s) added:[192.168.1.222]
    18:31:20.265 DBA [CM501003]: Connected: Database
    18:31:16.850 MediaServerConnected [CM112000] Media Server is connected
    18:31:16.610 CallMgr::findLocalIPs [CM501006]: Default Local IP address: [192.168.1.222]
    18:31:15.268 CallCtrl::thread [CM501007]: *** Started Calls Controller thread ***
    18:31:15.268 CallMgr::Initialize [CM501002]: Version: 6.0.650.0
    18:31:15.268 CallMgr::Initialize [CM501001]: Start 3CX PhoneSystem Call Manager
    18:29:48.133 LoadLicenceInfo [CM501010]: License Info: Load Failed

    I realise I might not get alot of help without paying (which I wont be doing while I am only testing), but I hope there might be someone out there who can give me a hand..

    Many thanks
     
  2. JayUK

    Joined:
    Jul 23, 2008
    Messages:
    4
    Likes Received:
    0
    Hi, thanks for helping out..

    If I called an extension that is set to goto vm after 15 secs it will just terminate the call after 15 secs.
    If I setup a receptionist it simply does not work - setup is all ok but no responce when calling attendant, says line not registered.

    I have installed v5.1 which is working ok, I get VM although it seems quite buggy, after a couple of uses it stopped working with just long silence but no cut offs.

    The issue could be sound hardware related? Another thing to note, in V6 the conference service failed to start every time, all other services start and work ok.. possibly the conference service stopped some of the other functions opperating.
    As you know the v5.1 does not have the conf system.

    hmmm god knows
     
  3. JayUK

    Joined:
    Jul 23, 2008
    Messages:
    4
    Likes Received:
    0
    Hi Matt,

    I've given up on on v6 for the mo..

    Using v5 as I said, the vm/audio systems worked to a point.. I found the problem was as soon as the sys tried to play an mp3 file through the vm/dr it would crash and I would have to restart services to get it going again, some troubleshooting got me looking at the direct show filters, sure enough direct show was crashing when trying to transcode an mp3. Although mp3's were playing fine on any player! so removed the culpret filters (nero digital audio filters) and it all works like a charm.

    It may be that v6 might work now the above problem has been sorted but I've spent about 3 days solid looking at and learning this voip/3cx stuff and my brain is in overload so im gonna have a rest and look at it all again another day..

    Upshot is that I have a fully working 3cx 5.1 sys to play with and demo to clients..

    Lastly would just like to say this is prehaps the most impressive free software I have come accross in 10 years as an IT consultant.. Well done 3cx.

    Thanks again Matt for taking the time to help me out.
     
  4. Anonymous

    Anonymous Guest

    JayUK,

    If you double-click an MP3 on the server, what happens?

    You must have an application capable of handling MP3s. If not, please install WMP and double-click an MP3 for initial setup.
     
  5. JayUK

    Joined:
    Jul 23, 2008
    Messages:
    4
    Likes Received:
    0
    I'm sure it will work alot better if I ever do a fresh setup for a client.

    Trouble is my test server has been well used over the last 3 years (without OS reinstall).

    The cause of my problems was that there were to many programs/codec fighting to decode mp3's and it caused a conflict/crash. WMP uses it's own selected codecs to decode mp3's and ignores the codec prioritys assigned in the codec register.

    Any I removed a few bad codecs and all is well.
     
Thread Status:
Not open for further replies.