No Voicemail Greeting Played For External Callers/No Message Recorded

Discussion in '3CX Phone System - General' started by olivermsubadra, Feb 25, 2016.

Thread Status:
Not open for further replies.
  1. olivermsubadra

    Joined:
    Feb 18, 2016
    Messages:
    33
    Likes Received:
    0
    I'm having trouble with getting the voicemail to work when an external caller is directed to an extension's voicemail.

    When making a call from one of our internal VOIP phones to one of our internal VOIP phones, the voicemail greeting is played and the caller can successfully record a message. However, when an external caller is directed to voicemail, no message is played and the line is absolutely silent. This means that the cannot save a recorded message.

    I've had a look at the firewall, and it doesn't look as though any sound is being rejected. The 3CX Activity Log doesn't give us any clue as to what might be going wrong. Is there a config setting I'm missing?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,848
    Likes Received:
    299
    I assume that outside calls to an extension, that answers, have no audio problems?

    Did this work in the past, or has it been this way right from start?

    Does the 3CX firewall test pass?

    Codec issue?
     
  3. olivermsubadra

    Joined:
    Feb 18, 2016
    Messages:
    33
    Likes Received:
    0
    It was a codec issue. I checked our VOIP provider's supported codecs, and they didn't match up with the codecs in the Advanced trunk settings. Changed them and everything worked beautifully. Thank you leejor!
     
Thread Status:
Not open for further replies.