NO way Audio

Discussion in '3CX Phone System - General' started by nickjhunt, Nov 30, 2015.

Thread Status:
Not open for further replies.
  1. nickjhunt

    Joined:
    Apr 25, 2013
    Messages:
    42
    Likes Received:
    0
    V14 server been working ok for a few weeks, all of A sudden getting complaints from remote client of one way or no Audio. Checked local firewall OK, ran 3CX firewall checker, no relevant errors. Suspected remote firewall so tested with a connection to a different 3cx server, all working ok.
    Looking at my Nat sessions table on the remote router I can see the following

    Phone IP port ext port peer IP Port interface
    192.168.10.70 14006 51254 192.168.16.201 9006 WAN1
    192.168.10.70 14006 51254 Ext ip_of PBX 5060 WAN1

    It looks like when the call is set up it is telling the remote client to connect to the RTP stream on a local interface 192.168.16.201. THis is the Lan IP of the PBX
    As far as I am aware there have been no changes on the site, I have tested remotely from 3 different sites with the same result.
    SIP ALG is disabled on all routers.
    PBX has single interface and fully resolved FQDN (Internal and External)
    help1
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,146
    Likes Received:
    211
    Have you tired logging into the phone and changing the IP for Server variable?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. nickjhunt

    Joined:
    Apr 25, 2013
    Messages:
    42
    Likes Received:
    0
    Yep, the setup is fine, phone registers using FQDN but when RTP stream is setup the destination appears to be the PBX's lan ip not the external IP.
     
  4. cwidmer62

    Joined:
    Dec 1, 2015
    Messages:
    5
    Likes Received:
    0
    Do you have a dynamic public IP-Adress and this problem only appears for remote clients?

    This problem can appear if your public IP has changed after you installed the 3CX phone system.
    It seems that your only option in this case is to make a backup, uninstall the 3CX phone system and reinstall it, giving your current public IP during the installation process - and then restore your backup.

    There are some other posts about this problem - it seems 3CX MIGHT rectify this in a future service pack, so that the public IP as retrieved by STUN is used.
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,594
    Likes Received:
    255
    I would certainly hope so, As i mentioned in another post, not everyone has the option, or is willing to spend the money, on a static IP. While it may be a given, for large companies, many small businesses can generally get by with a dynamic IP and the use of a DDNS service, if needed.
     
  6. nickjhunt

    Joined:
    Apr 25, 2013
    Messages:
    42
    Likes Received:
    0
    Solved!
    it appears that I installed it as nonat so the external IP is in fact an internal one. Issue only appears for remote phone clients.
    I will re-install and restore from backup.
     
  7. elisagrace

    Joined:
    Dec 3, 2015
    Messages:
    1
    Likes Received:
    0
    It will be better to take the advice of professional technician related to the field, he will correct the problem.
     
Thread Status:
Not open for further replies.