Non-Listed VoIP Provider - Les.net - Incoming Problem

Discussion in '3CX Phone System - General' started by SmokeyCarr, Dec 28, 2007.

  1. SmokeyCarr

    Joined:
    Dec 28, 2007
    Messages:
    7
    Likes Received:
    0
    Hello,

    I am trying to configure my system with Les.net. For some reason I am getting my 408 prefix appended twice:


    Kindly place all server logs in code and /code tags
    Code:
    00:46:40.835 AuthMgr::onAuthFailure [CM102001]: Authentication failed for SipReq: INVITE 4084088776798@75.144.248.141 tid=14951e4b cseq=INVITE contact=anonymous@64.34.181.47 / 103 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings 
    00:46:40.522 evt::CheckAuth::not_handled [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:4084088776798@75.144.248.141 SIP/2.0
    Via: SIP/2.0/UDP 64.34.181.47:5060;branch=z9hG4bK14951e4b;rport=5060
    Max-Forwards: 70
    Contact: [sip:anonymous@64.34.181.47]
    To: [sip:4084088776798@75.144.248.141]
    From: "anonymous"[sip:anonymous@64.34.181.47];tag=as3fe09e46
    Call-ID: 1d1132083ec76c073fd432a400b8d113@64.34.181.47
    CSeq: 103 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Date: Fri, 28 Dec 2007 08:45:01 GMT
    Proxy-Authorization: Digest username="1515420465",realm="3CXPhoneSystem",algorithm=MD5,uri="sip:4084088776798@75.144.248.141",nonce="12843305200:9c7dad99379ce4a7d3e8224b38ce1c99",response="29726bc8ab3e8c0ab84548ee4805fb32",opaque=""
    User-Agent: LES.NET.VoIP
    Content-Length: 0
    
     
    00:46:40.522 evt::CheckAuth::not_handled [CM302002]: Authentication failed due to unidentified source of: SipReq: INVITE 4084088776798@75.144.248.141 tid=14951e4b cseq=INVITE contact=anonymous@64.34.181.47 / 103 from(wire) 
    00:46:40.022 evt::CheckIfAuthIsRequired::not_handled [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:4084088776798@75.144.248.141 SIP/2.0
    Via: SIP/2.0/UDP 64.34.181.47:5060;branch=z9hG4bK1cd4149e;rport=5060
    Max-Forwards: 70
    Contact: [sip:anonymous@64.34.181.47]
    To: [sip:4084088776798@75.144.248.141]
    From: "anonymous"[sip:anonymous@64.34.181.47];tag=as3fe09e46
    Call-ID: 1d1132083ec76c073fd432a400b8d113@64.34.181.47
    CSeq: 102 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Date: Fri, 28 Dec 2007 08:45:01 GMT
    User-Agent: LES.NET.VoIP
    Content-Length: 0
    
     
    00:46:40.022 evt::CheckIfAuthIsRequired::not_handled [CM302001]: Authorization system can not identify source of: SipReq: INVITE 4084088776798@75.144.248.141 tid=1cd4149e cseq=INVITE contact=anonymous@64.34.181.47 / 102 from(wire) 
    00:46:30.881 ClientRegs::onSuccess [CM504004]: Registration succeeded for: 10001@Les Net 
    00:46:30.553 ClientRegs::Register [CM504003]: Sent registration request for 10001@Les Net 
    
    Outbound is fine - Incoming is the problem. When I call the number from a PSTN it goes immediately to the VoIP's voicemail system.

    Everything else is fine - This is an awesome system - 3CX pretty much automated everything - NICE JOB!!!

    Thanks.

    SmokeyCarr
     
  2. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,731
    Likes Received:
    41
    Thanks for your nice feedback :)

    In regards to your issue, did you check out this : (copied from a post in the 3Cx Phone system forum)

    Hi,

    In V5, configuring an unsupported VOIP provider is more flexible but also a tad more complex. Our default generic template works with many VOIP providers but not all. The good news is that you can make it work with a few mouse clicks.

    If you are not getting inbound calls, and are seeing this message in your server status log:

    [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:

    Then review this FAQ:
    http://www.3cx.com/support/source-identification-err-2.html

    This explains how you can quickly adjust the source identification so that calls from your VOIP provider are recognized.
     
  3. SmokeyCarr

    Joined:
    Dec 28, 2007
    Messages:
    7
    Likes Received:
    0
    Hello Nick,

    Thank yo uvery much for your reply. Well, if I learn how to follow instructions I can remove any problems before I post on the forum.

    Your reply worked!!! Yes, I viewed that posting before but, I did not follow your instructions completely :roll: the first time.

    For my second question I resolved the double 408 area code problem by loggin in to my VoIP providoer and removing the append 408 to every call.

    Ok. The only thing I have left to test is the the PSTN functionality then I will make my decision. I will test that today using either a PAP2 device or the Zoom ATA device.

    Just to let you know - I am beta testing your prodcut along with other vendors for a large pool of SMB looking for me to deploy IP PBX systems for them the 2nd week in January 2008.

    My test bench is composed of the following:

    2 T1 lines, 4 PSTNs, a Barracuda Networks Load Balancer configured for VoIP, Polycom I330 I430, and I501, Grandstream 100, Linksys SPA841 and 942 (Polycom is nice but NOT easy to setup and the support from Polycom is not good - They want you to use their certified XML tech's) Linksys was the easy one.

    Vendors:

    pbxnsip, Brekeke, Asterisk, trixnbox, Digium, PBXinaFlash and of course your peoduct.

    The best so far is your product - Gee! you really do not have to know much about SIP, VoIP, IP PBX, etc to configure your product. Just simply foloow your wizards and you are up and running in minutes.

    Kind of scary because I feel I should be making more of an input during the configuration :shock: I will post back here with my final outcome and decision.

    Again, thanks for your support.

    Cordially,

    Carl
     
  4. kenkwok14

    Joined:
    Mar 25, 2008
    Messages:
    4
    Likes Received:
    0
    Hi,

    I have the same problem, but the FAQ link "http://www.3cx.com/support/source-ident ... err-2.html" is not working. Would you please direct me to the proper link.

    Thanks
    Ken
     
  5. h2009

    h2009 Member

    Joined:
    Mar 15, 2008
    Messages:
    447
    Likes Received:
    0
    Can you post your server log, and let see if we can fix this!

    Oh yah - My 100th post!
     
  6. kenkwok14

    Joined:
    Mar 25, 2008
    Messages:
    4
    Likes Received:
    0
    This is the log:
    [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:100@3cxsip.mine.nu SIP/2.0
    Via: SIP/2.0/UDP 69.90.155.70;branch=z9hG4bK9563.4031eeb7.0
    Via: SIP/2.0/UDP 192.168.38.128:32420;received=99.229.185.190;branch=z9hG4bK-d87543-4d6ea66a37646275-1--d87543-;rport=22532
    Max-Forwards: 16
    Record-Route: [sip:69.90.155.70;ftag=872b4840;lr=on]
    Contact: [sip:900224@99.229.185.190:22532]
    To: "884388"[sip:100@3cxsip.mine.nu]
    From: "AppleMac"[sip:900224@fwd.pulver.com];tag=872b4840
    Call-ID: NDBjYzVkZGU3MDhhOGZlZDU2Y2NhYWJjM2M4NmM0YTY.
    CSeq: 3 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO
    User-Agent: X-Lite release 1011s stamp 41150
    Content-Length: 0
    P-hint: NON-LOCAL

    Tried change the "Source Indentification" to "Match Any Field" and "SIP Field" = From: Display Name and "Custom Value" = AppleMac. After changing, call can dial-in but cannot hang-up, the Lins Status shows in yellow?

    Thanks
    Ken
     
  7. h2009

    h2009 Member

    Joined:
    Mar 15, 2008
    Messages:
    447
    Likes Received:
    0
    Ah your using a mac! That could be the problem.
    You need to use the same codec as whats listed on the server. Sometimes the mismatch can cause problems. But still i dont think thats your problem. Does your system work when you call from 3CX client to 3CX client?
     
  8. kenkwok14

    Joined:
    Mar 25, 2008
    Messages:
    4
    Likes Received:
    0
    No, sorry I'm not using a Mac!

    Yes, they are the same codec.

    Of course, it works from 3CX client to 3CX client, it works from 3CX client to PSTN gateway, incoming calls from PSTN to 3CX clients are also no problem. The only problem is incoming calls from VoiP provider. It should be the incoming calls are not authicated properly.

    Any idea,
    Ken
     
  9. h2009

    h2009 Member

    Joined:
    Mar 15, 2008
    Messages:
    447
    Likes Received:
    0
    Ah sorry - i saw the frame AppleMac and guessed the calls were coming from there.

    Ok click on the les.net under the Gateway / Provider name, goto registration settings menu, under there make sure "required (optionally: authorized registration) for" is set to both in and out calls.

    Are you 100% sure your stun servers are working correctly with the correct ports set in 3CX.

    Also make sure you have the authorization ID, and external number set to the same thing, unless you have too different details in which case go with what the provider tells you.

    let me know how you get along.
     
  10. kenkwok14

    Joined:
    Mar 25, 2008
    Messages:
    4
    Likes Received:
    0
    yes, it has been set to both in and out calls already.

    Any more ideas?

    Thanks,
    Ken
     
  11. zubize

    Joined:
    Feb 28, 2011
    Messages:
    1
    Likes Received:
    0
    I have same problem. My connection is a Voip Trunk from Samsungp bx to 3cx pbx. the 3cx doesn't work.

     

Share This Page