Not able to connect to 3cx phone system from out side

Discussion in '3CX Phone System - General' started by gr2010, Dec 19, 2007.

Thread Status:
Not open for further replies.
  1. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    I have configured 3 extensions (soft phones at laptop) and all are working fine whenever I use at my home office. However, when I am out of home office and connect my lap top outside the home office using 3cx voip clinet 5, I am not getting connected to my home office. Also, I am not able to login to phone system from outside the office: for ex: http://192.168.2.103:5481

    Please let me if I have to change my voip client settings to access phone system or other extensions or should I change some setting at my home office networking or 3cx phone system so that I can access 3cx phone system from any where with ip address.
     
  2. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    192.168.x.x is a private IP address range, and as such unroutable on the internet by itself (which is why NAT exists).

    You have 2 choices:

    1) set up split DNS inside your network so that phone.foo.bar = 192.168.2.103 inside the network and phone.foo.bar = an internet IP address outside of the network.

    2) have 2 profiles on your laptop softclient - one for the internal ip address and the other for the internet ip address.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    How do I set up split DNS inside network?
     
  4. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    Following are the details from ipconfig:-

    IP Aaddress: 192.168.2.103
    DNS servers: 192.168.1.254

    Default gateway: 192.168.2.1

    DHCP server: 192.168.2.1

    Local area connection 11, 12 and 13 for 3cx

    I see Ethernet adapter local area connection 11

    .....12

    ....13

    11, 12 and 13 is for 3CX Open VPN connection, Connection # 2 and connection # 3 respectively
     
  5. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    To set up split DNS, you simply need to have your internal DNS server report a different result for a name lookup from the LAN as opposed to from the internet.

    In order to do this, consider an example scenario of phone.example.com which you would have registered at 100.100.100.100 on the internet and which you have your firewall port-forwarding to 10.10.10.10 on your LAN.

    You would therefore own the example.com domain on the internet and have "phone" as an A-record in DNS within that domain on the internet's DNS servers. You would then create a forward lookup zone on your LAN's DNS servers called example.com and create an A-record for "phone" pointing to 10.10.10.10

    This would give you the ability to look up phone.example.com from anywhere on the internet and it return 100.100.100.100 to your device, and to do the same on your LAN and it return 10.10.10.10 to the device.

    One thing you need to remember is that if you create example.com on your LAN and you recreate the "phone" A-record on it, that any lookup on the LAN for any other record you may have neglected to create (e.g. "www") will fail until you create each result in the LAN's DNS.

    HTH.

    Mike.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    I found out the problem:

    my LAN ip to login is: http://192.168.2.103:5481 which works great to login or use intercom.

    My External IP is: 68.221.12.152 (I found out now)

    I am connected to internet through modem router and then Linksys WRT54G router switch.

    Following are status from Linksys interface which I access using 192.168.2.1

    IP Address: 192.168.1.97
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.1.254
    DNS 1: 192.168.1.254

    I am trying out 3cx inside my office just testing extensions at present which works great.

    1) How do I access 3cx phone system from public ip address
    2) How do I enable 3CX Client access from out side my network (just to test the extensions.. there are two extensions in the home office and one at my laptop softphone. How does my client connects to extensions of the phone systems which are inside the LAN and my extension (client) from outside LAN (public ip)

    Pl. let me know how to configure based on the above scenario. thanks!
     
  7. silentfun

    silentfun Member

    Joined:
    Dec 11, 2006
    Messages:
    364
    Likes Received:
    0
    you have to setup a port forwarding or virtual server in your Internet Router

    you have to forward:

    your external adress ip:

    to your internal 3CX PBX ip: 192.168.2.103:5481

    if you want more then login to your 3cx admin page you have to open/forward some more ports.

    all this ports except the ports for internal calls you have to open / forward like i stated above if you need them.

    Andy
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,887
    Likes Received:
    190
    Issue with VOIP client as an external extension

    Hi,

    We have found an issue with using the VOIP client as an external extension. It relates to STUN resolution. We are working on it as we speak. We apologize for this inconvenience..... Give us today tomorrow....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    Please post reply in this subject topic so that I know when it works well... thanks!
     
  10. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    I opened all ports per your suggestion of Mr. Andy. still not able to login to phone system.
     
  11. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    I fixed the problem. ISP has modem (and i came to know it has router function also) and it is connected to my Linksys wireless router swtich for internal network.

    In the ISP modem config .. there was an option which says IP address pass through >> this was disabled.. After enabling this options I am able to login remote to the phone system at home office and also the WAN ip address is visible in the local systems.

    I first tried with Linksys tech support and they gave me a clue to check with ISP router config.. then I called the ISP to check this and found out there is one more router config with ISP which can enable or disable WAN ip address passthrough and there config interface is also neat and looks easier than Linksys... ..............Just to update if some is facing same problem...
     
Thread Status:
Not open for further replies.