Not installing - whats the issue ?

Discussion in '3CX Phone System - General' started by soamz, Jul 9, 2017.

Thread Status:
Not open for further replies.
  1. soamz

    Joined:
    Jul 9, 2017
    Messages:
    6
    Likes Received:
    0

    Attached Files:

  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Hello @soamz

    Please note that the 3CX phone system can only be installed on Debian 8 64bit as stated in the guide. If your VPS is running Ubuntu 16 then the phone system will not run.
     
  3. soamz

    Joined:
    Jul 9, 2017
    Messages:
    6
    Likes Received:
    0
    Ok I tried to install on a debian 8 server and getting this :


    Setting up 3cxpbx (15.5.1694.0) ...
    Minimal Linux kernel version 3.x is required. Please upgrade your kernel and launch /usr/sbin/3CXWizard again
    Processing triggers for libc-bin (2.19-18+deb8u4) ...
    Processing triggers for systemd (215-17+deb8u4) ...
    root@pbx:~#
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    Please update your kernel version to the recommended version so you can proceed with the installation.
     
  5. soamz

    Joined:
    Jul 9, 2017
    Messages:
    6
    Likes Received:
    0
    My VPS is a openVZ container.

    DOes that affect for 3cx ?
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    421
    We haven't tested installing 3CX in a VZ container so i cannot guarantee that this will work. Are you able to update the kernel?
     
  7. soamz

    Joined:
    Jul 9, 2017
    Messages:
    6
    Likes Received:
    0
    yes, same error
     
Thread Status:
Not open for further replies.