Not registering on LTE network

Discussion in 'Android' started by Peter Bata, Jan 26, 2017.

Thread Status:
Not open for further replies.
  1. Peter Bata

    Joined:
    Dec 22, 2016
    Messages:
    12
    Likes Received:
    0
    Running version 15.0.0 on our on-premise Debian server

    I am currently running 3CX in a test environment. Dynamic IP

    Devices:

    1 Cisco 303 IP phone
    1 iPhone 5 running latest 3CX client
    2 Samsung Galaxy Tab A running latest 3CX client

    All devices are "On Hook" when using internally over WiFi. Inbound / Outbound calls, and calls to all extensions functioning properly.

    When out-of-office, WiFi is turned off / Telus LTE gets switched on.

    Cannot get beyond "Registering" None of the devices go "On Hook" Tried re-provisioning same result.
    Verified port forwarding. All appears fine at router. FQDN provided by 3CX resolves to my public IP.

    Your assistance will be greatly appreciated.

    Peter
     
    #1 Peter Bata, Jan 26, 2017
    Last edited: Jan 27, 2017
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,479
    Likes Received:
    466
    Hello @Peter Bata

    Please make sure that you pass the firewall checker to rule out any firewall issues and also make sure that under extension settings / Phone provisioning the option "Use 3CX Tunnel for remote connections (3CX Client only)" is enabled.
     
    Peter Bata likes this.
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,870
    Likes Received:
    304
    Check the 3CX server log to see if there a registration attempt, and any error messages that may be associated with it. Don't forget the extension option, that by default, blocks registration from outside the local LAN.
     
    Peter Bata likes this.
  4. Peter Bata

    Joined:
    Dec 22, 2016
    Messages:
    12
    Likes Received:
    0
    First off, let me take a second to thank you for responding. I appreciate it.

    Firewall checker: All passed with success.
    Phone provisioning option is enabled.
     
  5. Peter Bata

    Joined:
    Dec 22, 2016
    Messages:
    12
    Likes Received:
    0
    Here is an update. After my original post yesterday, I decided to let things be as they were. I did not bother with the issue again till approx midnight when I decided to repeat what I had done earlier in the day. Which was to disable WiFI and enable LTE. I tried the same while out visiting a client today and everything functioned as expected.

    Bingo, just like that all devices went On Hook and I was able to make inbound and outbound calls. Go figure. I had not made any modifications whatsoever. Bizarre.

    Thank you all for chiming in. I appreciate it immensely.

    Peter
     
    #5 Peter Bata, Jan 27, 2017
    Last edited: Jan 27, 2017
  6. Peter Bata

    Joined:
    Dec 22, 2016
    Messages:
    12
    Likes Received:
    0
    Hello leejor. Are you referring to the section that I am making reference to in the attached screenshot. If so, that option was checked when I made an outbound call from a clients premises this morning. So, theoretically, I was outside my LAN. But was using one of our Samsung Tablets. The manual reads:
    • Disallow use of extension outside the LAN – Blocks any registrations from outside of the network. This setting applies to IP phones.
     

    Attached Files:

  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,870
    Likes Received:
    304
    That option is checked by default to prevent an extension being used outside that LAN without prior approval. Unless you were using VPN, the extension should not register if seen as being outside the local LAN. You should see a log to that affect.

    Is there a possibility that the original problem was a result of both Wifi and 4G being enabled at the same time?
     
  8. Peter Bata

    Joined:
    Dec 22, 2016
    Messages:
    12
    Likes Received:
    0
    No, I absolutely made sure to turn off Wifi followed by the enabling of the mobile data option on my tablets settings.

    As far as the LAN option goes: As I said in an earlier post, I was at a clients this morning with two of our tablets. (LTE enabled only) This client is definitely outside of our LAN

    Thank you very much for your time and assistance.


    Peter
     
  9. Peter Bata

    Joined:
    Dec 22, 2016
    Messages:
    12
    Likes Received:
    0
    By the way, when you say "server log", is that the same as the activity log that is available from the dashboard.

    Thank you
     
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,870
    Likes Received:
    304
    Sorry, I should have been more specific as there are more than one "server" logs. Activity log should show you registration attempts.

    It will show the IP, that the device is registering from (and port), which might explain why registration is allowed even if the option is set to prevent it.
     
    Peter Bata likes this.
  11. Peter Bata

    Joined:
    Dec 22, 2016
    Messages:
    12
    Likes Received:
    0
    Understood. Thank you. I downloaded and installed 3cxbinlogviewer. Seems to be quite thorough. Although, I haven't had much time to work with it yet
     
Thread Status:
Not open for further replies.