Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Nothing but problems with remote access

Discussion in '3CX Phone System - General' started by tech4, Sep 26, 2009.

Thread Status:
Not open for further replies.
  1. tech4

    Joined:
    Sep 15, 2009
    Messages:
    3
    Likes Received:
    0
    I have been seriously studying my butt off for the past few weeks, have read all of Kevin's slides, forums, everything I could get my hands on and even passed the certification test so I thought I had this stuff pretty well under control until yesterday when we tried to do some remote connectivity work and have run into nothing but problems. The scenario is that we have two offices setup by themselves and everything is working perfectly internally and the SIP trunks are working flawlessy. But yesterday we are out of town and wanted to do some bridging and remote connections, and this is where everything is falling apart. Both systems are using v8 RC2 on XP Pro SP3 and RC2 versions of 3CX Voip Phone and 3CX Assistant. Both firewalls were initially setup identically per Kevin's firewall slide with the following ports forwarded:

    5060 UDP
    9000-9049 UDP
    5090 Both

    Bridging the two systems together, slave system always was reporting destination tunnel doesnt appear to be running
    3CX Assistant logs in perfectly with or without tunnel on
    3CX Voip Phone will not connect to server, always returns destination not found.

    After searching and searching, we then added the following port forwarding:

    5480-5486 Both

    At this point we had made some progress:

    Bridge was up and functioning
    3CX Assistant logs in perfectly with or without tunnel on
    3CX Voip Phone connects with or without tunnel on
    Zoiper Softphone registers after several minutes but is not usable
    Cisco SPA509G registers after several minutes but is not usable

    Once registered, if you try and place a call, Zoiper appears to dial and then eventually times out with the following log entry:

    07:26:47.130 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:999@tech4.dnsdojo.com;transport=UDP SIP/2.0
    Via: SIP/2.0/UDP 192.168.2.101:5060;branch=z9hG4bK-d8754z-4ab92aece2e64663-1---d8754z-;received=97.93.95.221
    Max-Forwards: 70
    Contact: <sip:250@192.168.2.101:5060;transport=UDP>
    To: <sip:999@tech4.dnsdojo.com;transport=UDP>
    From: <sip:250@tech4.dnsdojo.com;transport=UDP>;tag=865be671
    Call-ID: NjgwM2I2NjU1ODZmOTM5OTU0YjUzZTBlMjcwOWVlOGE.
    CSeq: 1 INVITE
    Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, MESSAGE, OPTIONS, INFO, SUBSCRIBE
    User-Agent: Zoiper rev.4829
    Content-Length: 0

    While Zoiper trying to register, I am getting this message:

    07:41:17.552 [CM302001]: Authorization system can not identify source of: SipReq: SUBSCRIBE 250@tech4.dnsdojo.com tid=93900e1ff1e5e931 cseq=SUBSCRIBE contact=250@192.168.2.101:5060 / 1 from(wire)

    The Cisco509G acts a little different and although it takes a almost a minute, it does register, trying to call out results in the following message:

    07:43:35.365 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:999@tech4.dnsdojo.com SIP/2.0
    Via: SIP/2.0/UDP 97.93.95.221:38743;branch=z9hG4bK-e7a96aa0
    Max-Forwards: 70
    Contact: "101"<sip:101@97.93.95.221:38743>
    To: <sip:999@tech4.dnsdojo.com>
    From: "101"<sip:101@tech4.dnsdojo.com>;tag=855c462256300d53o0
    Call-ID: 5eea258e-7c7d4d7@97.93.95.221
    CSeq: 101 INVITE
    Expires: 240
    Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
    Supported: replaces
    User-Agent: Cisco/SPA509G-7.1.3
    Content-Length: 0

    What I am pretty confused about is why the 3CX Assistant would connect over the tunnel and the Softphone wouldnt at first when I followed the firewall instructions in Kevin's slides to the letter and had to open more ports.

    Second, why will a phone that works perfectly in the offices wont work remotely?

    Third, why Zoiper softphone won't work internally or externally

    I hope I have provided enough information here to help shed some light on this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. jim@itstod.se

    jim@itstod.se New Member

    Joined:
    Apr 7, 2008
    Messages:
    100
    Likes Received:
    0
    Put "tech4.dnsdojo.com" in Local SIP domain field under Settings - Advanced.

    Regards,
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tech4

    Joined:
    Sep 15, 2009
    Messages:
    3
    Likes Received:
    0
    This change had no effect on the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. jim@itstod.se

    jim@itstod.se New Member

    Joined:
    Apr 7, 2008
    Messages:
    100
    Likes Received:
    0
    Also make sure:
    - that your remote phone registers with the public IP address of the remote location. It looks like the Cisco phone does this (uses 97.93.95.221) but the Zoiper shows an internal IP address. To achieve this you must enable STUN on the remote phone.
    - forward TCP and UDP on port 5060 to your 3CX server.

    When this is done, please restart all 3CX services. Then run firewall checker to see if it passes all tests. If so - then try again. It should work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. tech4

    Joined:
    Sep 15, 2009
    Messages:
    3
    Likes Received:
    0
    Had already done all of the above suggestions, and yes, I agree, it should work. What I still dont get is why didnt the tunnel work for the 3CX softphone originally either.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.