Occasional Inbound Call Issue

Discussion in '3CX Phone System - General' started by dazred, Nov 11, 2010.

Thread Status:
Not open for further replies.
  1. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    Hi

    Having issue with latest 3CX SP3, we upgraded 2 weeks ago and now we get occassional issues with getting no external inbound calls. It lasts for about 5 minutes perhaps every 2/3 days at different times of the day. Our provider ran a wireshark capture during this time with a mobile phone to one of our DID's where it shows the PBX rejecting the call with '403 forbidden'. Outbound calls are unaffected. A restart of 3cx services will resolve the issue but with the issue lasting only 5 minutes or so we just leave it. The server shows no sighs of high cpu /memory issues, there is no 3cx server activty log indicating the issue that i can see-but i maybe looking at the wrong log -if so point me in the right direction

    cheers

    D
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    It seems like periodically 3CX is losing registration to the voip provider. It is so short a time because the pbx sends a reregistration request.

    Are you on a static IP?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Also you can lower the registration request period, please have a look at the attached screenshot.
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    The Server IP address is static and the time between registration is set to 60 seconds (if this should be lower what do you recommend i change that to?)

    Cheers

    D
     
  5. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi Dazred,

    If your quick enough or you can search trough the logs, get the logs of where it does not register for 4 minutes. Then I would be in a more comfortable positon to judge if the change is necessary
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    Hi
    cannot see any log for registration-possible due to no registration required-see attachement for current configuration.

    The issue happened again this morning-we lost incoming calls for over 20 minutes, i checked the server activity log during this time and there was no indication of registration requests. In ports/trunks status the provider remained registered/idle. Please advise

    Cheers

    D
     

    Attached Files:

  7. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    The Anti hacking settings were causing the issue, when incoming calls were being blocked it was because our incoming SIP server IP address was being blacklisted, finally found the server logs in 3cxphonesystem trace log when i did a test call during the outage:

    '14:38:39.802|.\Authorization.cpp(202)|Trace5|Authorization|AuthMgr::handle:IP **.***.*.* is in blacklist for another 1105 sec.'

    i had left the anti hacking settings in default after installing version 9. I have now doubled the failed auth requests and packets and reduced the time the 'abusive' ip id blacklisted
     
Thread Status:
Not open for further replies.