Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Office hours not respected

Discussion in '3CX Phone System - General' started by maxxer, Dec 22, 2016.

Thread Status:
Not open for further replies.
  1. maxxer

    Joined:
    Dec 14, 2016
    Messages:
    12
    Likes Received:
    0
    Hi.
    I'm trying to configure office hours but it doesn't seem to work. I'm trying both on a Google Cloud instance and on an on-premise local install.

    I'm using the default work hours, from 9 to 18, with 1h break from 13 to 14, but when I call the main (and only) trunk at 14:10 the responder still says office is closed.

    To recap the config:
    1. I have no extension specific hours
    2. I have no trunk specific hours
    3. In Settings > TimeZone I correctly have Europe/Italy
    4. The server time and timezone is correctly set
    Did I miss something in the config? Is there some cron or something else my pbx is not executing?
    thanks
     
  2. GiannosC_3CX

    GiannosC_3CX Guest

  3. maxxer

    Joined:
    Dec 14, 2016
    Messages:
    12
    Likes Received:
    0
    Yes, we're using the latest 15.0.60903.0

    We followed that, but the responder is not always in time with what I choose
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,396
    Likes Received:
    535
    From your description i understand that you are using break times and not out of office. Break times affect only extensions status as extensions should switch to Away during the break times. Your trunk should still be able to accept calls since you have no specific hours set there.
    So my question is where does that DID/Trunk lead and you are getting the offices are closed message?
    Have you enabled the Automatic set to available during office hours under the extensions forwarding rules?
     
  5. maxxer

    Joined:
    Dec 14, 2016
    Messages:
    12
    Likes Received:
    0
    I don't think the problem is with extension, but from the SIP Trunk configuration itself. I've set it this way:
    screenshot-internavigare.3cx.it 5001-2016-12-22-16-39-12.png
    so it's very simple: during office hours play an IVR, when outside play another. The problem here is that if I call say 10 minutes after the work hour started I still hear the outside office hours IVR.

    This is the work hours setup:
    screenshot-internavigare.3cx.it 5001-2016-12-22-16-44-15.png

    thanks
     
  6. maxxer

    Joined:
    Dec 14, 2016
    Messages:
    12
    Likes Received:
    0
    It looks like all the times are shifted by 1h. but system time is correct.
    I've also set timezone setting in php.ini, but still the same
     
  7. maxxer

    Joined:
    Dec 14, 2016
    Messages:
    12
    Likes Received:
    0
    I'm digging into the advanced parameters and I found two settings which might be relevant:
    • TIME_DST_SAVING_MINUTES: 60
    • TIME_UTC_OFFSET_MINUTES: 60
    We're in Europe/Rome, so currently UTC+1 (non DST). Is it possible that it's doing +120 minutes because of this?

    EDIT: DST param is set to 0
     
  8. fishblubcom

    Joined:
    Apr 16, 2009
    Messages:
    8
    Likes Received:
    0
    I am faced with exactly the same issue. The office hours are not respected, but when doing it manually it works.
    When looking at the logging it seems that the time settings are correct as the time shown is correct, BUT in the logging is the only place where I see American standard (AM/PM) where all the rest of the system uses the European standard (00:00-23.59).
     
  9. GiannosC_3CX

    GiannosC_3CX Guest

    Hi maxxer,

    Please check your OS time zone on Windows or on your Linux. For Linux please use this command "timedatectl status".

    About the above screenshot, the break time must be in the range of the office hours. Please check your time conditions more and for more details visit this link http://www.3cx.com/3cxacademy/videos/intermediate/time-day-routing/ on slide 5 and 16.

    upload_2016-12-23_9-44-55.png
     
  10. maxxer

    Joined:
    Dec 14, 2016
    Messages:
    12
    Likes Received:
    0
    that command didn't work in my Google Cloud console, but

    $ date +%Z
    CET


    so the TZ should be ok.
    The break times were there as attempt, but according to your description we need to change office hours so I'll remove them
     
  11. fishblubcom

    Joined:
    Apr 16, 2009
    Messages:
    8
    Likes Received:
    0
    Hello,

    I tried exactly the same, but it seems that it still does not work. This is the configuration I have right now.
    upload_2016-12-24_9-12-22.png
    upload_2016-12-24_9-13-32.png

    upload_2016-12-24_9-14-20.png

    But when I look at logging I see:
    upload_2016-12-24_9-15-22.png
    What is American Date style - Can this be the reason ?


    Last question, should i see something the events or activity log?
     
  12. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,396
    Likes Received:
    535
    Hello there,

    Can you explain exactly the behaviour you are experiencing? The way you have set up your office hours at the moment the extensions should switch to DND if the Auto Switch is enabled in extensions settings. Also with this configuration your trunks should also switch to out of office.
    Do they switch at a wrong time or they do not switch at all?
     
  13. fishblubcom

    Joined:
    Apr 16, 2009
    Messages:
    8
    Likes Received:
    0
    Hello YiannisH,

    The truck just don't switch at all - was also one of the reasons I asked if I could see anything in the activity log... just to check.
     
  14. EasyComp Zeeland

    Joined:
    Nov 6, 2016
    Messages:
    14
    Likes Received:
    1
    This is a support question right?

    I had this before; its really easy! connect to the server using ssh or something on Debian; check the date of ur machine using command; Date, if thats wrong, set it right ;)
     
  15. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,396
    Likes Received:
    535
    Also what service pack are you on?
     
  16. fishblubcom

    Joined:
    Apr 16, 2009
    Messages:
    8
    Likes Received:
    0
    The version I am on is
    upload_2016-12-29_18-35-59.png

    And yes the time is correct on the Windows Server.
     
  17. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    458
    Likes Received:
    75
    I just ran into this on a new v15 Windows installation and the temporary fix support had was for me to restart the "3CX PhoneSystem Database Server" service. Seems to be a bug and when you change office hours and save it, it isn't updating properly until you restart the services. Once restarted the PBX is honoring the new office hours just fine.

    Tech support said they will look into this more tomorrow to confirm if they can reproduce it..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. fishblubcom

    Joined:
    Apr 16, 2009
    Messages:
    8
    Likes Received:
    0
    Thanks... just restarted the service and will let you know when it works...
     
  19. antomassy

    Joined:
    Jan 10, 2017
    Messages:
    7
    Likes Received:
    0
    Hi, I have the same problem on my 3CX PBX Edition 15.0.60903.0 hosted on Google Cloud, office hours are not respected. Everything seems to be correct (timezone, virtual machine time/date and timezone ...). I tryed to restart the machine but nothing change...

    Any ideas about this problem?
     
  20. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,396
    Likes Received:
    535
    Does the system go in and out of office hours at some point or not at all? Can you send a screenshot of your office hours settings?
     
Thread Status:
Not open for further replies.