Old error messages resent

Discussion in '3CX Phone System - General' started by DBOD, Jan 10, 2013.

Thread Status:
Not open for further replies.
  1. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    Running 3CX version 11 SP2 on a Windows 7 machine.

    I restarted my system on December 21 and left town. On January 5th 2013 I got about a thousand email alerts with ID 4100 and ID 12289. It kind of freaked me out until I remotely logged into the system and saw that all was well. A closer inspection of the emails indicated that the errors themselves had happened months ago. A few months ago I had voip provider issues and many emails were sent during that time. But why would I get more now? Are these emails that got stuck and did not go out? Any way to look at the logs to see if these were actually sent on January 5th? I know the errors did not occur since the last restart. This actually continued to happen though the 7th. The messages seemed to be repeated groups of messages but it is too massive to investigate easily. I got about 5000 messages and they seem to have stopped by the 7th without restarting anything. Anyone else see this? While my system is working fine. Email alerts are useless if they behave like this. Thanks in advance.
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    I had the same issue, but it kept happening. It seemed like a bunch of error messages had been cached somehow and then on each new error there would be a mass of the old errors being sent with the new. It happened over several weeks and 3cx looked into the system, but as I recall did not really find anything. I was running win 7 Pro and I think v10, but do not really recall. I will go back into my mails and see if I can find something that may shed some light. if memory serves, there were a very, very limited number of people affected.
     
  3. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    I went back and looked.

    I was running the first release of V11. It started around the beginning of August and 3CX support and I exchanged numerous files and they got into the system a few times. Support felt that a disk with a bad sector may have been the issue, but I disagreed as the disk was an attached USB disk that was another client's drive that was being tested at the time. Nevertheless, it may still be something that could be affecting your system.

    In any event, I ended up installing SP1 shortly thereafter and deleting all the Windows logs from the event viewer. I can't say that one, the other or both collectively did the trick, but I have yet to experience the issue again.

    It was pretty vexing for a while as I had tried a number of other things to no avail. I would try something and it would appear that it was fixed as no emails arrived for a few days. However, this was because no new errors were being reported....but as soon as one did get reported then bang, hundreds would suddenly come through dating back months. I was only watching for trunk registration errors at the time.

    Good luck.
     
  4. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    The problem has spontaneously stopped after three days. I did not restart 3CX or my computer. I also deliberately induced a registration loss to trigger an event and subsequently only got the one appropriate email indicating that I had lost registration. Curiously I have not yet received an email indicating that registration was re-established. I thought it was set up to email me when registration changed. I have noticed in the past that I do not seem to get these things in pairs always. Maybe it will send it out randomly later LOL.

    (0) XXXXXXXX 1/11/2013 1:51:46 PM

    Event source: 3CXPhoneSystem

    Trunk L:10001(XXXXXXXXX) has changed status to unregistered. This means that no more calls will pass via this trunk. Please check your network connection and the voip provider or other SIP PBX

    Is there a log in 3CX that shows what emails were sent or attempted? Thanks.
     
  5. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    Here is a quick update. This may be a separate and unrelated problem. The last three emails that I received for 3CX are as follows. The last two show a lost registration followed by a registration which makes sense. The first two both show lost registration. I induced the first one and I know it reregistered, but where is the notification email for it registering again? Is it lost? Will it show up months later??

    (0) XXXXXX 1/11/2013 1:51:46 PM

    Event source: 3CXPhoneSystem

    Trunk L:10001(XXXXXXX) has changed status to unregistered. This means that no more calls will pass via this trunk. Please check your network connection and the voip provider or other SIP PBX

    (0) XXXXXX 1/11/2013 5:02:55 PM

    Event source: 3CXPhoneSystem

    Trunk L:10001(XXXXXXX) has changed status to unregistered. This means that no more calls will pass via this trunk. Please check your network connection and the voip provider or other SIP PBX

    (0) XXXXXX 1/11/2013 5:03:08 PM

    Event source: 3CXPhoneSystem

    Trunk L:10001(XXXXXXX) has changed status to registered.
     
  6. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Try restarting your system (hardware as well) and see what happens.
     
  7. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    Okay, I have resolved why I wasn't getting pairs of emails when registration was lost and regained.

    I use At&t U-verse as my ISP. They gave me an email address for the account and I used that as the "Reply" address in my email server setup.

    My business email was hosted by At&t/Yahoo Business webhosting. I used my business email address as the notification address.
    I used the smtp.att.yahoo.com server to send the emails. Technically you can not use unverified email address to send messages on the system. However, I can tell you in this situation a lot of the emails were getting through. No emails bounced back either. I was getting some emails notifying me that I had to "verify" if I wanted to send messages but they were coming back to the "Reply" address that I was never POPing or looking at. So I did not know they weren't being delivered. So after reconfiguring, I now get all the messages I expect to get.

    But that brings me back to my original question. When I started receiving old error messages by the thousands, were they being sent out by 3CX on that day or sitting on a server somehwere and finally got delivered to my mailbox?? Since At&t/Yahoo no longer want to cooperate on webhosting I have found it more desireable to move to another webhosting provider. Interestingly I had to jump through hoops to use my new provider's SMTP servers. For awhile there I was able to send messages to myself and anyone in my domain but no one outside of my domian was receiving them. No error messages no bounceback no need to verify messages just nothing! I have never seen anything like that. Are they sitting on a server somewhere? Disappeared? Did the pending Att/Yahoo webhosting break up cause them to clean up their servers and release a few thousand cached messages to me? I suspect we will never know but I doubt this was a 3CX issue.
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,366
    Likes Received:
    227
    In many cases (depending on the email viewer you are using), you can examine the email header in detail. That may tell you it's history. I know that Thunderbird, (and you may want to consider installing that, to test,) offers this option but most on-line email programmes , don't.
     
  9. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    All the time stamps show that they were sent on the same day they were received by me. That almost but not quite, suggests they lingered on my computer or inside 3CX for months before being sent out. That assumes the STMP server was time stamping the header properly when it first received it. Maybe maybe not.
     
  10. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    Service Pack 4 has this curious change in it.

    •3CX Phone System will now check Windows Event log Service to make sure it is running. This will avoid spamming of email notifications sent in the past.

    Is this the problem we have been discussing??
     
  11. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    Service packs 3 and 4 have not made this problem go away. It reared it's head again this morning for the first time since January 7th. Over the weekend 3CX attempted to send out old alerts via email three times. This happened in blocks of 250 emails many hours apart. My smtp server has a daily limit of 250 emails per user. There is no question that these are coming from the 3CX computer. It also appears that these are probably identical groups of messages. I did indentify one message that had been successfully sent out multiple times. It appears that 3CX not only stores these old alerts but also is not marking them as sent for some reason. I have restarted all services but will also have to reboot my machine soon for hardware upgrades so I probably won't anymore new information on this round.
     
  12. integrity2

    Joined:
    Nov 10, 2009
    Messages:
    22
    Likes Received:
    0
    I am having this problem as well. I'm getting 100's of emails every few days... Is there any way to resolve this?
     
  13. AndreasP_3CX

    AndreasP_3CX New Member
    3CX Support

    Joined:
    Feb 15, 2013
    Messages:
    196
    Likes Received:
    2
    Hi the issue should be fixed in v11 SP4. Did you try rebooting the system? if the problem is not solved please open a support ticket.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. southwest1

    Joined:
    Feb 28, 2011
    Messages:
    1
    Likes Received:
    0
    I am having this issue as well. We are running V11 SP4. Ours is continuously generating a message saying that an IP has been blacklisted and also a message about a call failing.
     
  15. Meg

    Meg

    Joined:
    Apr 3, 2012
    Messages:
    8
    Likes Received:
    0
    We have been having the problem as well. I believe it started when we upgraded to V11. We are on SP4 and we have restarted our system several times since then hoping to stop the emails but nothing has worked.
     
  16. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Try going to Windows control panel, administrative tools, event viewer and then going to each log under Windows and Applications and right click and clear the log. There is no need to save unless you have a reason. I had the problem late last year and this was one of the suggestions proffered by 3CX. I have not had the issue since, but as always, your situation might be different.
     
  17. kevin

    kevin Member

    Joined:
    Nov 23, 2006
    Messages:
    316
    Likes Received:
    1
    @ALL

    To give us the best chance of identifying this, we need the following information following an occurrence of bulk email sending of previous events:

    Logs of pbx in verbose mode (by generating a Support Info File). Please make sure you set the PBX logging to Verbose and restart all services before starting to track this issue, otherwise the logs will be incomplete.
    Eventlogs of the system (for application and system), in EVT or EVTX format
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. integrity2

    Joined:
    Nov 10, 2009
    Messages:
    22
    Likes Received:
    0
    Where do we need to send the requested information?
     
  19. kevin

    kevin Member

    Joined:
    Nov 23, 2006
    Messages:
    316
    Likes Received:
    1
    Make the information collected available as Dropbox links (or similar), and send the links to me in a PM.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. DBOD

    Joined:
    Jul 31, 2012
    Messages:
    45
    Likes Received:
    0
    Again this weekend it happened. On three different occasions large groups of old alerts were emailed. This is on a Windows 7 Pro machine running version 11 SP4 which has been rebooted. So if rebooting helps, it doesn't make the problem stay away.
     
Thread Status:
Not open for further replies.