One extension unregister and register few times a day

Discussion in '3CX Phone System - General' started by bdebruin, Mar 7, 2014.

Thread Status:
Not open for further replies.
  1. bdebruin

    Joined:
    Mar 7, 2014
    Messages:
    2
    Likes Received:
    0
    I am using a very simple setup (3CX version 12) with only two extensions. One extension being the 3CXPhone for Windows, the other one - causing the problem - is a Android 3CX client. The Android client is WiFi connected at all times. In the event log I can see this extension is being unregistered and within a few minutes registers agian. This happens between 5 - 10 times per 24 hour.

    What can be triggering the unregistering process. see logfile scrteenshot as attachement.

    Many thanks
    Bas
     

    Attached Files:

  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    I've seen that happen, not only on the 3CX Android phone, but on WiFi VoIP handsets as well. If I'm at a hotspot, and turn on the 3CX phone, then check my phone to find it still registered after an hour, I'm pleasantly surprised. Some places it doesn't seem to last more than 10 minutes before I have to force it to re-register. I have to assume that has something to do with the router at that particular location. I was in Germany last year with an unlimited 3G SIM, even while staying in an area with good reception, I noticed that the phone would not be registered at times when I checked it.

    There may be any number of reasons for this. You can try to shorten the time between registrations to see if that makes any difference. Or "play" with the keep alive settings. You can test the phone on another network, to see if that is an issue. It may also be something else running on the phone itself, that steals focus from the 3CX App. it might be a battery saving feature trying to kick in.

    I have also seen similar unregister/register logs from ATA's that should not be doing that either, as they are set to re-register every 28 minutes.
     
  3. bdebruin

    Joined:
    Mar 7, 2014
    Messages:
    2
    Likes Received:
    0
    Thank you!

    I lowered the time between registrations and that solved the issue. For unknown reasons the time was set at 3600 for this extension and I lowered it to the defaut 60.

    Kind regards,
    Bas de Bruin
     
Thread Status:
Not open for further replies.