One way audio 3CX iPhone using Tunnel

Discussion in '3CX Phone System - General' started by MB1, Aug 14, 2012.

Thread Status:
Not open for further replies.
  1. MB1

    MB1

    Joined:
    Nov 2, 2007
    Messages:
    39
    Likes Received:
    0
    Hi,

    I am only getting oneway audio when using the 3CX iPhone app with 3CX Tunnel. I am using 3CX V11 and IPhone app 1.1.5.
    I have two way audio when I connect directly (non tunnel). Any ideas?

    Regards,

    MB

    Logs:
    14-08-2012 06:21:36.568 L:6.1[Extn] Sending: OnSendResp Send 487/INVITE from 0.0.0.0:0 tid=PjpI4KVXB0zi7LgfSBuhXTKfWC87az5On9 Call-ID=JqirrqJWyAXlD-dqbBQBqU0PSjM0dtZ5:
    SIP/2.0 487 Request Terminated
    Via: SIP/2.0/TCP 127.0.0.1:5080;branch=z9hG4bK-d8754z-PjpI4KVXB0zi7LgfSBuhXTKfWC87az5On9-2---d8754z-;rport=1662;received=192.168.30.31
    Via: SIP/2.0/UDP 101.78.139.3:24130;branch=z9hG4bK-d8754z-tunneltid-1---d8754z-;rport
    Via: SIP/2.0/UDP 127.0.0.1:5065;rport=5065;received=127.0.0.1;branch=z9hG4bKPjpI4KVXB0zi7LgfSBuhXTKfWC87az5On9
    To: <sip:deletedbyMB@192.168.30.31:5060>;tag=0111de6b
    From: "deletedbyMB"<sip:15@192.168.30.31:5060>;tag=kfFMNRlTaCx2Ps1KjwOfiSrqyOM84FcK
    Call-ID: JqirrqJWyAXlD-dqbBQBqU0PSjM0dtZ5
    CSeq: 13229 INVITE
    Content-Length: 0
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    You do realize that there is a forum specific to the iPhone, or, maybe not.

    You also need to provide a bit more information...how are you connecting...3G, WiFi (remotely)? Does this happen either way? Only using one? At all WiFi hotspots?
     
  3. MB1

    MB1

    Joined:
    Nov 2, 2007
    Messages:
    39
    Likes Received:
    0
    No Leejor I didn't realise that there was a specific forum for the IPhone, but I do now..... thank you.

    The connection is WIFI remote. I haven't tried it on 3G and can't until I return to the U.K. I haven't tried it on the local network, or indeed any other network.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    Which direction do you have audio?
    In the log you posted I see a few ports listed...5060 ,5065 but I don't see 5090, which is the port normally used for the tunnel.

    The tunnel will usually just work, or it won't, black or white. As everything is sent over a single port, if the tunnel is able to make a connection, then audio is (usually) also able to pass. I have been on trips, using hotspots, where a normal connection will not work (no registration), but the tunnel will. Have you tried it from more than one WiFi hotspot , some do have a nasty tendency to block certain ports.
     
  5. MB1

    MB1

    Joined:
    Nov 2, 2007
    Messages:
    39
    Likes Received:
    0
    Hi Leejor,

    I tried it on a different hotel's WiFi network and it worked fine. I am now using the same problem WIFI network as before and it works without a hitch. It must have been a short term local network issue.

    Thanks for your help.

    Regards,

    MB
     
Thread Status:
Not open for further replies.