Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

One-way audio and 30 second disconnections

Discussion in '3CX Phone System - General' started by amarsys, Apr 5, 2011.

Thread Status:
Not open for further replies.
  1. amarsys

    Joined:
    Mar 24, 2011
    Messages:
    17
    Likes Received:
    0
    I'm continuing my exploration of 3CX. So far I haven't quite managed to get a proper call going! The main issues are either 1-way audio (external caller cannot hear me but I can hear them) or the call disconnects after 30 seconds.

    My configuration:
    Gradwell SIP trunk.
    2 x ADSL.
    2 x external static IP.
    Draytek 2955 firewall configured as per the instructions on the 3CX support pages including QoS. Only one of the static IPs is forwarded to the 3CX server. The SIP ALG setting is turned off (checked via Telnet).
    3CX running within a Windows 2008 VM on HyperV.
    Yealink T26 phone provisioned as per the 3CX support pages (and I have tried various manual adjustments on the STUN and NAT traversal within the phone).
    Everything works on internal calls between the Yealink and internal 3CX softphones.

    From searching through the forum I can see that 30 second disconnections are usually a STUN problem. Since I have a static IP I thought I should be able to disable STUN, but it is pretty clear that I can't at the moment. So my question is, should I persevere trying to get it to work with STUN disabled, or is STUN basically a "good thing"? I have been through so many variations I am not quite sure what has worked and what hasn't, but basically I can either have a 2-way conversation for 30 seconds or a 1-way conversation (which may also disconnect after 30 seconds).

    Call quality on the Yealink is excellent by the way, I was not expecting the sound to be so good.
     
  2. amarsys

    Joined:
    Mar 24, 2011
    Messages:
    17
    Likes Received:
    0
    A follow-up, I think without STUN is considered the best way - if you can get it to work. One thing that seems to help if you are not using STUN is the Settings - Global Options - check the Enable keep alives box.
     
Thread Status:
Not open for further replies.