Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

One way audio on internal WIFI

Discussion in 'iOS' started by Andy Wright, Feb 15, 2017.

Thread Status:
Not open for further replies.
  1. Andy Wright

    Joined:
    Feb 15, 2017
    Messages:
    1
    Likes Received:
    0
    Hi all

    Device Info
    -------------------------------------------------------
    Phone Model: [iPhone]
    Generation: [5S, 6, 6S, 7]
    Firmware Version: [10.2]
    Jailbreak: [NO]
    Cydia Installed: [NO]

    Issue Info
    -------------------------------------------------------
    Handset: [Phone|
    Contacts: [Local]
    Connection: [WiFi]
    Server: [Internal]

    I have a very strange one that's bugging me. The Desktop app and desk phones are all working perfectly but the IOS app has a one-way (they can hear me but I can't hear them) audio issue when on the internal WIFI. When I disable WIFI on the phone, switching to 3G or even on an external WIFI they work perfectly. It seems to be restricted to the office.

    I have the extension set to PBX delivers Audio and like I said, everything works fine except this.

    Has anyone else seen this before who can offer any advice?
     
    #1 Andy Wright, Feb 15, 2017
    Last edited: Feb 15, 2017
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,528
    Likes Received:
    71
    Hi Andy

    Can you please do the following test for me?

    Go to the Settings/Accounts/account settings and delete/clear the "External PBX IP", then back to Accounts, back to Settings and tap Register. Now its should not register on 3G or externa WiFi, but only on internal WiFi. Please tell us if it behaves like this and also if the audio issue still persist. Also, please tell us the PBX version (V14 or V15) and iOS client version (as in Settings/ About)

    Thanks
    vali

    P.S After the test, to restore the deleted "External PBX IP", in Settings tap Re-Provision.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DSXDATA

    DSXDATA New Member

    Joined:
    Oct 20, 2015
    Messages:
    185
    Likes Received:
    64
    Next, ask if there is a SonicWALL router in the mix. If so,
    1. Go to the VoIP tab (or Firewall tab, depending on the device’s web interface)
    2. Near the top of the page, make sure Enable Consistent NAT is checked.
    3. Further down on the page, make sure Enable SIP Transformations is unchecked.
    4. Save your changes.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.