One-way audio (send) behind small router

Discussion in '3CX Phone System - General' started by PCTurnkey, Aug 15, 2012.

Thread Status:
Not open for further replies.
  1. PCTurnkey

    Joined:
    Mar 26, 2012
    Messages:
    31
    Likes Received:
    0
    I have little snag in completing the deployment of our new phone system. We have 7 phones deployed and working well on our network. I have a problem with 2 other phones (grandstream GXP2120s) connecting, though. One is set at a far end of the complex behind a small router (WRT54GL) and the other one is connected in the tech room which is behind another small router (same kind).

    Issue 1: I have the other 7 phones all set with static IPs. They find the 3CX server and are in use and make great sounding calls.
    These 2 phones wouldn't register this way. The only way they would register was to set to DHCP (giving them a 192.168.1.x address issued from these small wifi routers and not one of the static IPs [10.0.0.x] like the rest). I feel like this is a basic networking problem that I've solved many times, but for some reason am not figuring it out right away with these phones.

    Issue 2: These two phones are also only sending audio (receiving extension can hear the audio), but aren't receiving any audio. I read something about having to set the STUN server in the Grandstream GUI, but am unclear about that. Also think it might be something to do with NAT traversal, but haven't found great documentation about that.

    Any help and suggestions are appreciated.
    Thanks.
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Is there a reason for the other routers being in place? Yes, it sounds like a NAT issue.
     
  3. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,947
    Likes Received:
    179
    can you put the phone in front of the secondary router and use pass thru in the phone to the router ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Move the phone i front of the firewall than its definitely a firewall issue. Did you enable port forwarding on the the firewall on port 5060 so that the calls can get out to the WAN? Also if NAT is enabled on those firewalls, disable and attempt an call as well. Though these are just suggestions, post a log while attempting to make an outbound call from on of those handsets that will give more information on the problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,357
    Likes Received:
    224
    How are the two additional "small" routers connected? Do they go out on an ISP (WAN port)? Or, are they connected to the internal network and only there to provide WiFi in their local area? If its the later then you may want to consider turning them into Access Points from the main network. If it's the former, then you will encounter any issues that a remote extension may encounter.

    Have a look over...

    http://www.3cx.com/blog/docs/provisioning-a-remote-extension/
    http://www.3cx.com/blog/voip-howto/remote-extensions/
    https://www.3cx.com/blog/voip-howto/troubleshooting-direct-remote-extension/
     
  6. PCTurnkey

    Joined:
    Mar 26, 2012
    Messages:
    31
    Likes Received:
    0
    Thanks for the replies. I printed those articles and added them to "the Binder."

    Here's what I did with the suggestions provided:

    I examined the network and decided to change one of the routers to an access point, eliminating one of the issues.

    For the second router, this was not an option (for security reasons). I followed the articles and, first and foremost, made firewall exceptions and port forwarding rules. We run a firewall device (pfSense), so was a little more involved, but once those rules were made (following the list of ports provided in the articles), and made in the router (just 3 ranges opened in small router - 5060, 5090, 9000-9049), everything worked. I was able to set the addresses back to what I had them statically, and it was all good.

    Thanks,

    Alex
     
Thread Status:
Not open for further replies.