Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

One way audio through VPN

Discussion in 'Android' started by inteq, Oct 9, 2015.

Thread Status:
Not open for further replies.
  1. inteq

    Joined:
    Jan 8, 2013
    Messages:
    42
    Likes Received:
    0
    Hello,

    This is more a heads up than a question.

    Using 3CX PBX v14 with 3CX Phone for Android v14.
    The phone must connect through VPN to be able to register.

    Problem.
    Using 3CX Phone for Android results in one way audio. Internal extension can hear, the phone (external through VPN) cannot.
    The phone registers with the correct VPN IP and both parties ring and answer.
    No matter what I tried, I cannot get past the one way audio problem.

    Solution.
    On Android, use CSipSimple.
    Install, input User name, password and server and it works right out the box!
    Incredible, but a third party software is able to interconnect and work with 3CX PBX way better and faster then the proprietary software.

    I spent one week debugging this problem thinking somehow it was my fault (the way i setup the router, VPN, PBX)
    Time wasted for nothing.
    This is clearly a problem on 3CX end and frankly I am starting to ask myself why I pay maintenance for a software that fixes nothing. I never had one way audio problem with Asterisk, which may I remind you, is free.
    I am in no way a guru in PBX deployment, but logic dictates that if a software works and the other one does not, with the same configuration, you found your culprit.

    If you have one way audio between an Android and an internal extension while using VPN, try using CSipSimple.
    It worked for me, might work for you.
    I am in no way affiliated with CSipSimple. Just a happy user that found a solution for his problem.

    All the best
     
  2. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Hi, when you open a post like this ideally for us would be very useful if you post a log of this call.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. luminite

    Joined:
    Jun 24, 2013
    Messages:
    4
    Likes Received:
    0
    I had this problem - to clarify, no outbound audio from the extension. Fixed it by opening UDP port 5090 on my firewall. TCP 5090 was already open, but the RTP/audio is obviously UDP. Worked for me anyway...
     
Thread Status:
Not open for further replies.