One way audio with Iphone 3G connection

Discussion in 'iOS' started by zhangjx99, Nov 20, 2010.

Thread Status:
Not open for further replies.
  1. zhangjx99

    Joined:
    May 26, 2010
    Messages:
    51
    Likes Received:
    0
    Hi there,

    3CX Iphone client is working fine with Wifi connection, but with 3G connection, one way audio issue.

    Since it work fine with Wifi connection, I suspect 3G vendor (in Singapore) has blocked SIP port 5060, is there any alternative?

    I don't want to change server SIP port 5060 just because of the Iphone extension issue. is there anyway to setup both 5060 and 5061 port at the same one 3CX server?

    Thanks.
    JX
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    If your sip vendor is at fault altough since the call is connected it might not be that then you can create a VPN from your phone to your PBX. THis should conquer the problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Sarah Hastings

    Joined:
    Nov 24, 2010
    Messages:
    15
    Likes Received:
    0
    You cannot place both SIP port servers on one 3CXPhone system. But you could try the other way around by utilizing some kind of proxy SIP address or changing software.
     
  4. gmcfad

    Joined:
    Feb 14, 2010
    Messages:
    3
    Likes Received:
    0
    I'm having the same issue - but with both 3CX for Iphone and Acrobits. Both have one way audio. (outbound from Iphone)
    But FRING works fine. And when I make the test calls to an extension here on my home PBX if almost sounds like the outgoing audio in looped back from my internal extensions. But again, only with 3CX for Iphone and Acrobits. Very strange.
     
  5. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,217
    Likes Received:
    89
    3CXPhone and Acrobits are both direkt SIp Clients, Fring is an Proxy Service with a "Man in the Middel" the codec is porpierty so not directly sip and not been catched by the provider, to get arround this issue use VPN from the Iphone or we wait if we can make a tunnel service for the phone as we have it on windows.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. tworhythms

    Joined:
    Sep 15, 2010
    Messages:
    19
    Likes Received:
    0
    I had this problem as well. For those who are experiencing one-way audio over 3G you can try asking your provider to enable VPN access (might be a small monthly charge). Then you will need to modify the APN settings on the iPhone (there are guides on the internet on how to do this). The big issue is that most internet.com APNs and others are behind NAT. When your provider enables VPN access on your account it should provide you with a public IP on your iPhone (at least it does with Rogers in Canada). I can now make 2-Way audio calls over 3G with my iPhone!!
     
  7. Sarah Hastings

    Joined:
    Nov 24, 2010
    Messages:
    15
    Likes Received:
    0
    Is there any other way around the provider thing....Something like SIP settings or what?
     
Thread Status:
Not open for further replies.