One-Way Audio with Tunnel

Discussion in '3CX Phone System - General' started by JRayfield, Jul 10, 2011.

Thread Status:
Not open for further replies.
  1. JRayfield

    Joined:
    May 9, 2010
    Messages:
    17
    Likes Received:
    0
    As I'm trying to get my Grandstream GXP2010 (at home) working with my 3CX Phone System (at my office), I've found that if I use the 3CX Tunnel, then I have audio only one-way (from the 3CX Phone System to my GXP2010).

    If I don't use the tunnel, then everything works perfectly (audio both ways).

    What should I check for to resolve this problem?

    John Rayfield, Jr.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    Are you using the 3CX proxy server at home for tunnel access? I wasn't aware that a set alone (other than the 3CX phone, or a set through the Proxy server) can make use of the tunnel feature.

    Does the 3CX Server log (in Verbose) show any issues?
     
  3. JRayfield

    Joined:
    May 9, 2010
    Messages:
    17
    Likes Received:
    0
    I have a GXP2010 here at home, and I'm running the Proxy Server on my computer here at home. The 3CX PBX is at my office/shop/datacenter.

    Calls go through from the GXP2010 to my cell phone, just fine, except that I only have audio from the cell phone back to the GXP2010. Audio from the GXP2010 is not making it through the 3CX PBX (maybe it isn't making it through the Proxy Server - I'm not sure).

    The only thing that I've noticed that I'm suspcious of, is this line, found in the 3CX Server Activity Log, after one of the calls is made and I've hung up:

    "20:34:07.184 [MS105000] C:38.1: No RTP packets were received:remoteAddr=127.0.0.1:10014,extAddr=0.0.0.0:0,localAddr=127.0.0.1:7068"

    This does seem to indicate that the 3CX PBX isn't getting audio from the Proxy Server, but I'm not familiar enough, yet, with the 'inner workins' of VoIP phone systems to understand this line, yet.

    John Rayfield, Jr.
     
  4. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    If that is the actual output from the activity log it is showing a problem with understanding the IP addresses. Do you have STUN enabled on the phone?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    Since the set is running behind the Proxy Server, I'm not sure it is a set STUN issue, in fact STUN should be unnecessary on the set. It may be other settings on the set, or a config issue (firewall issue/settings on the PC running Proxy Server?) with the Proxy server or router at that end.
     
  6. JRayfield

    Joined:
    May 9, 2010
    Messages:
    17
    Likes Received:
    0
    I've tried with both STUN enabled and disabled on the GXP2010. It didn't make any difference.

    Which ports should be open and pointing to the computer on which the proxy server is running?

    John Rayfield, Jr.
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    If the Proxy Server is using the tunnel, then I should think that it would just need port 5090 forwarded to it.
     
  8. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    3
    I have this or a similar issue with extensions that are behind the 3cx Proxy Tunnel.

    When one extension makes a call to another extension behind the same tunnel, the audio is one way. Calls made from behind the tunnel to destinations not behind the tunnel are fine.

    Setting "pbx delivers audio" for the remote extensions does resolve the issue, but I'm not sure why that should be required.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.