one way audio

Discussion in '3CX Phone System - General' started by callidus, Apr 2, 2010.

Thread Status:
Not open for further replies.
  1. callidus

    Joined:
    Jul 29, 2009
    Messages:
    17
    Likes Received:
    0
    hi,
    I have a problem, only one side can hear the audio, sometimes is it afected to both sides. i realy don't know what to do anymore.. it just won't work.. can somebody please help me to understand the problem and I hope find a solution?

    so.. there are 3 wireshark logs attached

    snom-behind-nat is the snom that i have in the office - (ext 15) it never gets audio
    server-behined-nat - is the server where the 3cx phone system is installed on and it is behind a second nat..
    snom-lan is a snom phone on the lan side of the server. - (ext 16) it gets audio (most times)

    I tried to make a call form 15 to 16.. in that case either neither gets audio or both phones get audio; when I call ent 15 form ext 16, 16 can hear the audio, but i don't get anything; or nobody gets audio.
    so i don't understand what's wrong.. i have tried all kinds off diferent setting on the phones and on the pbx, but nothing helped..
    could it be the stun or the nat? we are using mikrotik routers rb450g; i can only suspect that the nat changes the port when the packet goes out. but i don't know how to solve that problem.

    another interesting thing is that the outbound and inbound calls are ok.. we can normaly call out or recieve calls. just the extensions are problematic..

    please help.. i'm desperate..
    thanx..
     
  2. callidus

    Joined:
    Jul 29, 2009
    Messages:
    17
    Likes Received:
    0
    I think I can't upload attachmets.. I can send them to pm if somebody wants to help.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    No audio problems are almost always because some of the necessary ports are either blocked or 3CX doesn't know where to send the packets. Make sure that all of the needed ports are forwarded, on the router at the 3CX end, as per the 3CX setup info. Make sure that any "remote" extensions are set to use STUN. Make sure that the routers that you're using don't have a problem handling SIP or require certain settings to be changed to allow SIP to work correctly. If you are able to do so, connect the remote sets to the net, bypassing the router (Public IP,no STUN). See if they work correctly. If so then it is the router at the remote end you need to look at.
     
  4. callidus

    Joined:
    Jul 29, 2009
    Messages:
    17
    Likes Received:
    0
    thank's for reply..

    as far as I can see, the rtp packets that are send from my phone are not the same as in the sdp.. probably the nat changes the src. port. The phone should send the the packet from 11798, but the server gets it from 1093 and than tries to send it back to port 11798.
    I'm not sure if it is right that way..
     
  5. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    Please ensure that the wireshark capture is showing request to send audio to the correct External Ip address. Also please ensure you are using stun.3cx.com.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. callidus

    Joined:
    Jul 29, 2009
    Messages:
    17
    Likes Received:
    0
    jitendrasnv, I don't think the phone is damaged..

    mfm, I'm using stun.3cx.com, and yes, the external IP is correct..

    could it be something else? somekind of setting I should set up?
     
  7. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Could you please send me wireshark captures? (I've sent you my emails one week ago)
    Without this information it is not possible to answer selected question.

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.