only external ip

Discussion in '3CX Phone System - General' started by bluetel2, Feb 10, 2012.

Thread Status:
Not open for further replies.
  1. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    6
    Hi all,

    we have dedicated serveur which have only 1 network card. this network card is link directly to net. ip addresse ip external add. so the ip add of pbx is a loopback network card.

    my problem is with tunnel. when i said to my tunnel to listen on local ip -> finaly external ip, my 3cx phone connect but there is no audio.

    when i said to tunnel on 3cx phonse system to liste local ip 192.168.2.1 (my loppback ip) 3cx phone can connect.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    789
    Likes Received:
    45
    Hi,

    I ran into the same problem with one of my customers. It was solved as follows

    In 3CX server
    Go to Settings >> Network >> 3CX Tunnel >> Local IP - select your external (WAN) IP-address
    Go to Settings >> Advanced >> Advanced >> Local SIP domain - fill in your WAN IP-address

    In 3CXPhone
    Go to Account Settings >> My Location >> I am out of the office - fill in the WAN IP-address of the 3CX server
    Select Use 3CX Tunnel >> Local IP - fill in the WAN IP-address of the 3CX server.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    6
    Tks frank for your reply,

    in fact i test this but i have only 1 way audio. on 3cx phone connected is write 127.0.0.1:54585 ?? i don't know why this port and why this ip?

    tks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    789
    Likes Received:
    45
    Hi,

    I presume that you also, in 3CX server, set STUN as follows
    Tick the Turn off stun server
    Public IP is your WAN IP-address
    Select Network card Interface to your WAN IP-address

    The port number, when the 3CXPhone connects to the server by tunnel or direct, is never port 5060. It is always random. Why? I don’t know. But it works.
    Also the IP-address 127.0.0.1 is normal if 3CXPhone is connect via a tunnel.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    6
    it's 2008 policies problem

    tks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.